<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:og="http://ogp.me/ns#" xmlns:fb="https://www.facebook.com/2008/fbml" lang="en" xml:lang="en" dir="ltr">
<head>
<link rel='stylesheet' href='/css/minified.css?132' media='none' onload='this.media="all"' />
<link rel='stylesheet' href='/css/required_7.min.css?132' media='all' />
<script type='text/javascript' src='/assets/7cc0f43f/jquery.min.js'></script>
<script type='text/javascript' src='/js/required_7.min.js?132'></script>

<script> (function(w,d,s,l,i){ if (w['GTM_install']) return; w['GTM_install']=1;
w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});
var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';
j.async=true;j.id='m_dataLayer_'+(GTM_install++);j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-TCK74FR'); </script>
<!--[if IEMobile]> <meta name="mobileoptimized" content="0" /> <![endif]-->
<meta charset="utf-8" />
<meta name="language" content="en" />
<meta name="google" content="notranslate" />
<meta http-equiv="Content-Language" content="en" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="canonical" href="https://www.brandbucket.com/names/yesharvest" />
<meta name="robots" content="noarchive" />
<meta name="googlebot" content="noarchive" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, user-scalable=yes, minimum-scale=1, maximum-scale=1" />
<link rel="alternate" type="application/rss+xml" title="BrandBucket RSS Feed" href="http://feeds.feedburner.com/brandbucket" />
<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
<link rel="alternate" type="application/rss+xml" title="BrandBucket RSS Feed" href="http://feeds.feedburner.com/brandbucket" />
<meta name="thumbnail" content="https://www.brandbucket.com/sites/default/files/logo_uploads/321303/stamped_preview_w7.png" />
<link rel="image_src" href="https://www.brandbucket.com/sites/default/files/logo_uploads/321303/stamped_preview_w7.png" />
<title>Yesharvest.com is For Sale | BrandBucket</title>
<meta name="description" content="Buy the domain name Yesharvest.com and launch your business with a premium domain and a high quality logo." />
<meta property="og:image" content="https://www.brandbucket.com/sites/default/files/logo_uploads/321303/stamped_preview_w7.png" />
<meta property="twitter:account_id" content="30301929" />
<meta property="og:type" content="article" />
<meta property="og:description" content="Buy the domain name Yesharvest.com and launch your business with a premium domain and a high quality logo." />
<meta property="article:tag" content="farming" />
<meta property="article:tag" content="food" />
<meta property="article:tag" content="fruit" />
<meta property="article:tag" content="gardening" />
<meta property="article:tag" content="grains" />
<meta property="article:tag" content="groceries" />
<meta property="article:tag" content="harvest" />
<meta property="article:tag" content="nutrition" />
<meta property="article:tag" content="nutritive" />
<meta property="article:tag" content="produce" />
<meta property="article:tag" content="vegetables" />
<meta property="article:tag" content="veggies" />
<meta property="og:title" content="Yesharvest.com is For Sale | BrandBucket" />
<meta property="og:url" content="https://www.brandbucket.com/names/yesharvest" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="msvalidate.01" content="ABE48D7CF71EC311C19499AB849AFEAE" />
<script type="text/javascript"> var baseUrl = "//www.brandbucket.com",serverUrl = "//www.brandbucket.com",loadTime = 1608636553,m_loadTime = (new Date).getTime(),popupTimer = 0,popupTimerType = 0,onLoadFunctions =[],m_reCapchaLoaded,m_forceRightMenu = false,leftMenu_lastState,google_userID = '';var onloadFunction = function(){if (typeof leftMenu_lastState === 'undefined') leftMenu_lastState ={};};if (window.addEventListener) window.addEventListener('load',onloadFunction);else window.attachEvent('onload',onloadFunction);</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1625379-2"></script>
<script async src="https://www.refersion.com/tracker/v3/pub_3e3ece134abc1c8ae203.js"></script>
<script>
	  window.dataLayer = window.dataLayer || [];
	  function gtag(){dataLayer.push(arguments);}
	  gtag('js', new Date());
	  gtag('config', 'UA-1625379-2');
	  gtag('config', 'AW-797206400');
	  if (typeof google_userID != "undefined" && google_userID.length) gtag('set', { 'user_id': google_userID });
	  onLoadFunctions.push(site_guardRefersionPageload);
	</script>
<link rel='preconnect' href='https://www.google.com' crossorigin='use-credentials'>
<link rel='preconnect' href='https://www.google-analytics.com' crossorigin='use-credentials'>
<link rel='preconnect' href='https://www.googleadservices.com' crossorigin='use-credentials'>
<link rel='preconnect' href='https://www.googletagmanager.com' crossorigin='use-credentials'>
<link rel='preconnect' href='https://stats.g.doubleclick.net' crossorigin='use-credentials'>
<link rel='preconnect' href='https://googleads.g.doubleclick.net' crossorigin='use-credentials'>
<link rel='preconnect' href='http://refersion.com' crossorigin='use-credentials'>
<link rel='preconnect' href='https://q.quora.com' crossorigin='use-credentials'>
<link rel='preconnect' href='https://a.quora.com' crossorigin='use-credentials'>
<link rel='preconnect' href='https://m.stripe.com' crossorigin='use-credentials'>
<link rel='preconnect' href='https://stripe.com' crossorigin='use-credentials'>
<link rel='preconnect' href='https://m.stripe.com' crossorigin='use-credentials'>
<link rel='preconnect' href='https://px.ads.linkedin.com' crossorigin='use-credentials'>
<link rel='preconnect' href='https://connect.facebook.net' crossorigin='use-credentials'>
<link rel='preconnect' href='https://www.facebook.com' crossorigin='use-credentials'>
<link rel='preconnect' href='http://linkedin.com' crossorigin='use-credentials'>
<link rel='preconnect' href='https://px.ads.linkedin.com' crossorigin='use-credentials'>
<link rel='preconnect' href='https://www.twitter.com' crossorigin='use-credentials'>
<link rel='preconnect' href='https://analytics.twitter.com' crossorigin='use-credentials'>
<link rel='preload' href='/css/fonts/Roboto-Bold.ttf' as='font' crossorigin>
<link rel='preload' href='/css/fonts/Roboto-Regular.ttf' as='font' crossorigin>
</head>
<body class='allow_hover brandbucket_body header_top_menu_visible is_landingPage'>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TCK74FR" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
 
<script type="text/javascript"> document.body.style.visibility = 'hidden'; </script>
<div class='header_top_menu'>
<div class='defa_width'>
<div class='head_search_bar d_none'><div>
<div class='input_area'><input type='text' onkeyup='site_topbarSearchKey(this, event)' value='' onclick='focusme(this)' /></div>
<a href='#' onclick='site_hideHeaderSearch(); return reloadSiteContents({q: $(".head_search_bar input[type=text]").val(), trigger_GA_event: true })' class='head_search_go'><img src='/images6/icon_search_wh.png' alt='Icon search' /></a>
</div></div>
<div class='head_logo darkerback'>
<a href='/' class='head_logo_img'><img src='/images7/head_logo2.png' alt='BrandBucket' /></a>
</div>
<div class='head_burger_menu onload_hidden'>
<a href='#' class='menu_icon'><img src='/images7/icon_burger.png' alt='Icon Burger menu' /></a>
</div>
<div class='head_cart_icons onload_hidden'>
<a href='/cart' class='cart_icon header_icon' rel='nofollow'>
<img src='/images6/icon_cart_blk.png' alt='Icon Cart' />
<span></span>
</a>
<a href='/favorites' class='fav_icon header_icon' rel='nofollow'>
<img src='/images6/icon_heart.png' alt='Icon Favorites' />
<span></span>
</a>
<a href='#' class='search_icon'>
<img src='/images6/icon_search_wh.png' alt='Icon Search' />
</a>
</div>
<div class='head_menu_links onload_hidden darkerback'>
<a href='/names' class='browse_all_names_label' onclick='return reloadSiteContents("/names")'>all names</a>
<a href='/styles' class='browse_by_style_label' onclick='return reloadSiteContents("/styles")' guardcategorycloud='browse_by_style'>by style</a>
<a href='/industries' class='browse_by_industry_label' onclick='return reloadSiteContents("/industries")' guardcategorycloud='browse_by_industry'>by industry</a>
<a href='/resources' class='browse_resources_label' onclick='return reloadSiteContents("/resources")' guardcategorycloud='browse_resources'>resources</a>
<a href='/faq' class='browse_faq_label' onclick='return reloadSiteContents("/faq")' guardcategorycloud='browse_faq'>faq</a>
</div>
</div>
</div>
<div class='browse_by browse_by_style darkerback2'></div>
<div class='browse_by browse_by_industry darkerback2'></div>
<div class='browse_by browse_resources darkerback2'></div>
<div class='browse_by browse_faq darkerback2'></div>
<div class='page_contents_inner scrollable'>
<div class='head_dummy onload_hidden'><div class='color'><div class="defa_width">
</div></div></div>
<div class='content_area main_bk'>
<div class='before_list'>
<div style='display: none' itemscope itemtype="https://schema.org/BreadcrumbList">
<div itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a itemprop="item" href="https://www.brandbucket.com/">
<span itemprop="name">BrandBucket</span>
</a>
<meta itemprop="position" content="0" />
</div>
<div itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a itemprop="item" href="https://www.brandbucket.com/names">
<span itemprop="name">Names</span>
</a>
<meta itemprop="position" content="1" />
</div>
<div itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a itemprop="item" href="https://www.brandbucket.com/names/yesharvest">
<span itemprop="name">yesharvest.com</span>
</a>
<meta itemprop="position" content="2" />
</div>
</div>
<div class='bk_FF'><div class='domain_landing_page content_width' style='padding-top: 10px; padding-bottom: 30px; text-align: center' data-snap-ignore='true' data-id='321071' data-business-name='yesharvest.com' data-business-name-logo='/sites/default/files/logo_uploads/321303/large_yesharvest.png' data-business-name-description='Yes Harvest: A simple combination that implies mindful food production.' data-business-name-possible-uses='A farming equipment store. A produce company. A grocery store.' data-business-name-categories='[{"title":"Agriculture & Farming","alias":"agriculture-farming-business-names"},{"title":"Food & Beverage","alias":"food-beverage-business-names"}]' data-business-name-keywords='["farming","food","fruit","gardening","grains","groceries","harvest","nutrition","nutritive","produce","vegetables","veggies"]' data-business-name-brand='Keyword' data-business-name-variant='Com' data-business-name-ec-categ='{&#34;1&#34;:&#34;industries\/agriculture-farming-business-names&#34;,&#34;2&#34;:&#34;industries\/food-beverage-business-names&#34;}' data-business-name-price='2795' data-business-name-price-currency='USD' data-business-name-bbprice='840' data-business-name-price-currency='USD' itemscope itemtype='https://schema.org/Product'>
<meta itemprop='name' content="yesharvest.com">
<meta itemprop='brand' content="yesharvest.com">
<meta itemprop='mpn' content="321071">
<meta itemprop='sku' content="yesharvestcom">
<meta itemprop='image' content='/sites/default/files/logo_uploads/321303/large_yesharvest.png' />
<div class='domain-lander-splitter'></div><div class='domain-lander-head1'><div class='h_15 need_4cols'></div><h1 class='float_left left domain-lander-name'>The domain name<br /><span>YESHARVEST.COM</span><br />is for sale. </h1><div class='domain-desc-price medium float_right'><span class='defa' itemprop='offers' itemscope itemtype='https://schema.org/Offer'>$2,795<sup>.00</sup><span> USD</span><meta itemprop='price' content='2795' /><meta itemprop='priceCurrency' content='USD' /><meta itemprop='availability' content='https://schema.org/InStock' /><meta itemprop='url' content='https://www.brandbucket.com/names/yesharvest' /><meta itemprop='priceValidUntil' content='2020-12-22' /></span></div><div class='clear'></div></div><div class='domain-lander-head2'><div class='smart_header_container'>
<div class='smart_header' background_id='1' image_width='580' image_height='380'>
<img src='/sites/default/files/logo_uploads/321303/large_yesharvest.png' alt='yesharvest.com' image_width='360' image_x='110' image_y='90' />
<a href='#' nid='321071' onclick='site_sendEvent("Favorite", "Add", "Heart"); return site_updFavorite(this)' title='Save yesharvest.com to favorites' style='float: right; margin: 10px 10px -17px 0'>
<img src='/images5/heartverydark.png' width='17' height='14' />
</a>
</div>
<div class='smart_header' background_id='2' background_image='/images2/nice_bk1.jpg' image_width='1600' image_height='1044' background_center='58'>
<img src='/sites/default/files/logo_uploads/321303/large_yesharvest.png' alt='yesharvest.com' image_width='150' image_rotate='-65' image_x='345' image_y='725' />
<img src='/sites/default/files/logo_uploads/321303/large_yesharvest.png' alt='yesharvest.com' image_width='310' image_rotate='-5' image_x='620' image_y='497' class='desaturate' />
<img src='/sites/default/files/logo_uploads/321303/large_yesharvest.png' alt='yesharvest.com' image_width='90' image_rotate='-5' image_x='560' image_y='316' />
<img src='/sites/default/files/logo_uploads/321303/large_yesharvest.png' alt='yesharvest.com' image_width='75' image_rotate='12' image_x='1115' image_y='435' />
<div style='text-align: right; display: inline-block; position: relative' image_rotate='12' image_width='140' image_x='1119' image_y='478' font_size='12'>
<span style='font-size: 1em; line-height: 1.5em'>John Doe<br />CEO<br /></span>
<span style='font-size: 0.8em; line-height: 1.4em'>
john.doe@yesharvest.com<br />
(310) 555-1221
</span>
</div>
</div>
<div class='smart_header' background_id='3' background_image='/images2/nice_bk2.jpg' image_width='1600' image_height='1044' background_center='30'>
<img src='/sites/default/files/logo_uploads/321303/large_yesharvest.png' alt='yesharvest.com' image_width='340' image_rotate='-20' image_x='280' image_y='250' />
<div style='text-align: right; display: inline-block; position: relative' image_rotate='-20' image_width='250' image_x='490' image_y='330' font_size='22'>
<span style='font-size: 1em; line-height: 1.5em'>John Doe<br />CEO<br /></span>
<span style='font-size: 0.8em; line-height: 1.4em'>
john.doe@yesharvest.com<br />
(310) 555-1221
</span>
</div>
</div>
<div class='smart_header' background_id='4' background_image='/images2/nice_bk3.jpg' image_width='1600' image_height='1044' background_center='47'>
<img src='/sites/default/files/logo_uploads/321303/large_yesharvest.png' alt='yesharvest.com' image_width='240' image_x='645' image_y='430' />
<div style='text-align: right; display: inline-block; position: relative' image_width='180' image_x='733' image_y='680' font_size='14'>
<span style='font-size: 1em; line-height: 1.5em'>John Doe<br />CEO<br /></span>
<span style='font-size: 0.8em; line-height: 1.4em'>
john.doe@yesharvest.com<br />
(310) 555-1221
</span>
</div>
</div>
<div class='smart_header' background_id='5' background_image='/images2/nice_bk4.jpg' image_width='1600' image_height='1044' background_center='52'>
<img src='/sites/default/files/logo_uploads/321303/large_yesharvest.png' alt='yesharvest.com' image_rotate='-17' image_width='350' image_x='420' image_y='435' />
<div style='text-align: right; display: inline-block; position: relative' image_rotate='-17' image_width='180' image_x='695' image_y='715' font_size='14'>
<span style='font-size: 1em; line-height: 1.5em'>John Doe<br />CEO<br /></span>
<span style='font-size: 0.8em; line-height: 1.4em'>
john.doe@yesharvest.com<br />
(310) 555-1221
</span>
</div>
</div>
<div class='smart_header' background_id='6' background_image='/images2/nice_bk5.jpg' image_width='1600' image_height='1044' background_center='45'>
<img src='/sites/default/files/logo_uploads/321303/large_yesharvest.png' alt='yesharvest.com' image_width='510' image_x='520' image_y='350' />
<div style='text-align: right; display: inline-block; position: relative' image_width='250' image_x='896' image_y='585' font_size='22'>
<span style='font-size: 1em; line-height: 1.5em'>John Doe<br />CEO<br /></span>
<span style='font-size: 0.8em; line-height: 1.4em'>
john.doe@yesharvest.com<br />
(310) 555-1221
</span>
</div>
</div>
</div><div class='smart_header_selector'><div class='smart_header_selector_1' style='background-image: url(/sites/default/files/logo_uploads/321303/large_yesharvest.png); background-size: 42px auto;' onclick='return smart_showheader(1)' class='selected'></div><div class='smart_header_selector_2' style='background-image: url(/images2/nice_bk1_thumb.jpg?2)' onclick='return smart_showheader(2)'></div><div class='smart_header_selector_3' style='background-image: url(/images2/nice_bk2_thumb.jpg?2)' onclick='return smart_showheader(3)'></div><div class='smart_header_selector_4' style='background-image: url(/images2/nice_bk3_thumb.jpg?2)' onclick='return smart_showheader(4)'></div><div class='smart_header_selector_5' style='background-image: url(/images2/nice_bk4_thumb.jpg?2)' onclick='return smart_showheader(5)'></div><div class='smart_header_selector_6' style='background-image: url(/images2/nice_bk5_thumb.jpg?2)' onclick='return smart_showheader(6)'></div></div></div><div class='domain-lander-head1'><div class='need_4cols'><span itemprop='description'>Yes Harvest: A simple combination that implies mindful food production.</span> <span style='white-space: nowrap;'>Possible uses: </span>A farming equipment store. A produce company. A grocery store.</div><div class='domain-lander-actions'><a href='#' class='lander_btn lander_inquire_btn' onclick='return site_lander_show_inquire()'><img src='/images7/icon_chat_wh.png' alt='Inquire' />Inquire</a><a href='#' class='lander_btn lander_inquire_btn' nid='321071' onclick='site_sendEvent("Favorite", "Add", "Button"); return site_updFavorite(this)'><img src='/images7/icon_heart_wh.png' alt='Add to favorites' /> Favorite</a><a href='#' nid='321071' class='lander_btn lander_buy_btn' onclick='site_sendEvent("BuyNow", "Click", "LandingPage"); return site_updCartObject(this)'><img src='/images7/icon_cart.png' alt='Buy Now' />Buy Now</a></div><div class='allow_3cols allow_2cols allow_1cols'><span>Yes Harvest: A simple combination that implies mindful food production.</span> <span style='white-space: nowrap;'>Possible uses: </span>A farming equipment store. A produce company. A grocery store.<div class='clear h_30'></div></div><div class='domain-lander-select' id='select-kc'><a href='#' onclick='return site_lander_show_tab(this, "kc-1")' class='selected'>Keywords</a><a href='#' onclick='return site_lander_show_tab(this, "kc-2")'>Categories</a></div><div class='domain-lander-select-tab' id='tab-kc-1'><a href='https://www.brandbucket.com/search?q=farming&source=domain' onclick='return reloadSiteContents({ keyword: "farming", source: "domain"});' rel='nofollow'>farming</a><a href='https://www.brandbucket.com/search?q=food&source=domain' onclick='return reloadSiteContents({ keyword: "food", source: "domain"});' rel='nofollow'>food</a><a href='https://www.brandbucket.com/search?q=fruit&source=domain' onclick='return reloadSiteContents({ keyword: "fruit", source: "domain"});' rel='nofollow'>fruit</a><a href='https://www.brandbucket.com/search?q=gardening&source=domain' onclick='return reloadSiteContents({ keyword: "gardening", source: "domain"});' rel='nofollow'>gardening</a><a href='https://www.brandbucket.com/search?q=grains&source=domain' onclick='return reloadSiteContents({ keyword: "grains", source: "domain"});' rel='nofollow'>grains</a><a href='https://www.brandbucket.com/search?q=groceries&source=domain' onclick='return reloadSiteContents({ keyword: "groceries", source: "domain"});' rel='nofollow'>groceries</a><a href='https://www.brandbucket.com/search?q=harvest&source=domain' onclick='return reloadSiteContents({ keyword: "harvest", source: "domain"});' rel='nofollow'>harvest</a><a href='https://www.brandbucket.com/search?q=nutrition&source=domain' onclick='return reloadSiteContents({ keyword: "nutrition", source: "domain"});' rel='nofollow'>nutrition</a><a href='https://www.brandbucket.com/search?q=nutritive&source=domain' onclick='return reloadSiteContents({ keyword: "nutritive", source: "domain"});' rel='nofollow'>nutritive</a><a href='https://www.brandbucket.com/search?q=produce&source=domain' onclick='return reloadSiteContents({ keyword: "produce", source: "domain"});' rel='nofollow'>produce</a><a href='https://www.brandbucket.com/search?q=vegetables&source=domain' onclick='return reloadSiteContents({ keyword: "vegetables", source: "domain"});' rel='nofollow'>vegetables</a><a href='https://www.brandbucket.com/search?q=veggies&source=domain' onclick='return reloadSiteContents({ keyword: "veggies", source: "domain"});' rel='nofollow'>veggies</a></div><div class='domain-lander-select-tab d_none' id='tab-kc-2'><a href='https://www.brandbucket.com/industries/agriculture-farming-business-names?source=domain' onclick='return reloadSiteContents({ category: "agriculture-farming-business-names", source: "domain"});'>Agriculture & Farming</a> <a href='https://www.brandbucket.com/industries/food-beverage-business-names?source=domain' onclick='return reloadSiteContents({ category: "food-beverage-business-names", source: "domain"});'>Food & Beverage</a> </div></div><div class='clear'></div> </div></div>
<div class='bk_FF'><div class='content_width'>
<div class='domain-lander-what domain-lander-what1'>
<h2 class='large_h'>What Do I Get?</h2>
<div>
<h3><img src='/images6/icon_gift.png' alt='Gift'>A Premium Domain Name</h3>
BrandBucket names are curated by branding experts.
</div><div>
<h3><img src='/images6/icon_paint.png' alt='Paint'>Professionally Designed Logo</h3>
A creative logo created by a highly-skilled logo designer.
</div><div>
<h3><img src='/images6/icon_bills.png' alt='Bills'>Transparent Pricing</h3>
No hidden fees, no escrow fees. Guaranteed delivery.
</div>
</div>
<div class='domain-lander-what domain-lander-what2'>
<h2 class='large_h'>What's Next?</h2>
<div>
<h3><img src='/images6/icon_cart_blk.png' alt='Checkout'>Checkout Securely</h3>
We accept all major credit cards, Bitcoin or wire transfers.
</div><div>
<h3><img src='/images6/icon_info.png' alt='Tracking'>Follow Transfer Instructions</h3>
An agent will contact you with personalized information.
</div><div>
<h3><img src='/images6/icon_delivery.png' alt='Delivery'>Confirm Delivery</h3>
Payment is held in escrow until you've received the name.
</div>
</div>
<div class='h_30 clear'></div>
</div></div>
<div class='bk_EA'><div class='lander_faq_area content_width'>
<div class='h_50'></div>
<h2>Frequently Asked Questions</h2>
<br />
<div class='faq_question faq_q_closed' itemscope itemprop='mainEntity' itemtype='https://schema.org/Question'>
<h3 class='medium' onclick='site_toggle_faq_q(this)' itemprop='name'>What happens after I purchase a domain name from BrandBucket?</h3>
<div class='faq_answer' itemscope itemprop='acceptedAnswer' itemtype='https://schema.org/Answer'><div itemprop='text'>
<p>Every name on the BrandBucket marketplace is exclusively listed with BrandBucket. That means that all of our sellers are very
responsive, making for quick domain transfers.<br />A dedicated BrandBucket agent will manage your domain transfer from beginning
to end, ensuring a secure and easy transaction. They will manage the receipt of the domain into one of BrandBucket’s secure registrar
accounts and then complete the transfer to you.</p>
<p><b>1. Verification and registrar choice</b><br />
After we receive the payment and verify it, we will reach out via email to confirm which registrar you want the domain transferred to.
We also provide a link to our tracking system, where you can communicate with us, check on the status of your transfer, view your invoice,
and download your logo files.</p>
<p>In most cases, if a domain is moved between accounts at a single registrar, the transfer is quick and usually completes within 48 hours.
If a domain changes registrars (in other words, you would like to move it away from where it is currently registered), the transfer is
slower. The total transfer time can then be anywhere from 48 hours to 7 days.</p>
<p>BrandBucket has vetted and supports the following registrars:<br><ul>
<li>GoDaddy</li>
<li>Namesilo</li>
<li>Uniregistry</li>
<li>NameCheap</li>
<li>Google Domains</li>
<li>Network Solutions</li>
<li>Name.com</li>
<li>Dynadot</li>
<li>Amazon Route 53</li>
<li>123 Reg</li>
<li>Gandi</li>
</ul></p>
<p><b>2. We request the name from the seller.</b><br />
Once we know where you would like the domain transferred, BrandBucket will request the domain from the seller. All of our sellers are very
responsive, making for a quick process. </p>
<p><b>3. Transfer the name into your account</b><br />
As soon as we receive the name from the seller, we start the transfer into your account and guide you through the whole process.</p>
<p><b>4. Verify with the buyer that the transfer is complete</b><br />
Once we confirm that you have received the name, we consider the escrow process to be complete. Only then do we release payment to the
domain seller. </p> </div></div>
</div>
<div class='faq_question faq_q_closed' itemscope itemprop='mainEntity' itemtype='https://schema.org/Question'>
<h3 class='medium' onclick='site_toggle_faq_q(this)' itemprop='name'>Why choose BrandBucket?</h3>
<div class='faq_answer' itemscope itemprop='acceptedAnswer' itemtype='https://schema.org/Answer'><div itemprop='text'>
<p>Established in 2007, we are the original business name marketplace. Every year, we sell 1000s of premium domains to entrepreneurs and businesses like you.</p>
<p>All of our domain names are handpicked by branding and linguistics experts based on rigorous criteria. You can rest assured that if a domain
is on the BrandBucket marketplace, it is a top-tier business name. </p>
<p>Almost one out of every four names sold on BrandBucket is sold to a repeat buyer or a referral, which means that people who buy from us once,
keep coming back for more.</p> </div></div>
</div>
<div class='faq_question faq_q_closed' itemscope itemprop='mainEntity' itemtype='https://schema.org/Question'>
<h3 class='medium' onclick='site_toggle_faq_q(this)' itemprop='name'>Why choose a .com domain name from BrandBucket?</h3>
<div class='faq_answer' itemscope itemprop='acceptedAnswer' itemtype='https://schema.org/Answer'><div itemprop='text'>
<p>The .com extension is a brand in itself. As the default domain extension of the internet, having a .com domain that is an exact match to your brand
name has numerous advantages:<br /><ul>
<li><b>Familiarity</b> - People are familiar with .com. Most of the brands and websites they already trust, use the .com extension. Therefore, it
serves as a subtle indicator that your business is a legitimate one. A recent study by the NCC Group, a global expert in cybersecurity and risk
mitigation, found that roughly half of the consumers are uncomfortable visiting websites ending with a non .com extension, and only 9% are comfortable doing so.</li>
<li><b>Brand Protection</b> - When you own the .com version of a domain name, you have the official online version of that name. Owning an
exact-match .com can protect your brand name, as it is unlikely another serious business would use the same name when the .com extension is taken.</li>
<li><b>Easy to Communicate</b> - .com domains are also easy to communicate. When people hear or see your business name without a TLD, they will
inevitably assume it ends in .com, making it easy for them to find you online.</li>
</ul></p> </div></div>
</div>
<div class='faq_question faq_q_closed' itemscope itemprop='mainEntity' itemtype='https://schema.org/Question'>
<h3 class='medium' onclick='site_toggle_faq_q(this)' itemprop='name'>What can I do with the domain I purchase from BrandBucket?</h3>
<div class='faq_answer' itemscope itemprop='acceptedAnswer' itemtype='https://schema.org/Answer'><div itemprop='text'>
<p>Once you have received the name into your registrar account, you will be able to: </p>
<ul>
<li>Use the domain as your website address. </li>
<li>Setup email addresses, for instance, sales@yesharvest.com.</li>
<li>Use the domain and logo on business cards and other materials.</li>
</ul>
<p>If you don’t have a website built yet, you can put up a simple coming soon page, or you can just leave it until you are ready. You don’t need to
do anything right away. Because you own the domain name, you can take your time.</p> </div></div>
</div>
<div class='faq_question faq_q_closed' itemscope itemprop='mainEntity' itemtype='https://schema.org/Question'>
<h3 class='medium' onclick='site_toggle_faq_q(this)' itemprop='name'>Are logos included with my BrandBucket order? Can I request edits?</h3>
<div class='faq_answer' itemscope itemprop='acceptedAnswer' itemtype='https://schema.org/Answer'><div itemprop='text'>
<p>Our talented community of logo designers designs all logos on the BrandBucket marketplace. They are paid for their efforts, and BrandBucket owns
all copyrights for the logos. We will transfer the full copyright for the logo to you upon purchase of the domain name. </p>
<p><b>Logo files are delivered to you in the following formats:</b></p>
<ul>
<li>High-resolution image file (PNG)</li>
<li>Editable vector file (.AI)</li>
</ul>
<p><b>Editing your design</b></p>
<p>Vector (AI) files are entirely editable in programs such as photoshop and illustrator, so you or your designer can make desired changes. If needed,
we can make basic color changes/small tweaks to the logo for you after purchase. If you are looking for a complete redesign, we can connect you with a
designer from our talented design community at their discretion and price.</p> </div></div>
</div>
<div class='faq_question faq_q_closed' itemscope itemprop='mainEntity' itemtype='https://schema.org/Question'>
<h3 class='medium' onclick='site_toggle_faq_q(this)' itemprop='name'>Is a domain name from BrandBucket 100% unique?</h3>
<div class='faq_answer' itemscope itemprop='acceptedAnswer' itemtype='https://schema.org/Answer'><div itemprop='text'>
<p>All of our business domains are carefully chosen for their standout branding qualities. There is only one {domain.com}. However, there may well be
other businesses that are using the same brand name. In fact, with common keyword names, it is likely. That is why owning the .com is so essential.
In holding the .com, you immediately establish your business as the most official version of that name. It's unlikely any serious business is going
to use a brand name where the .com domain is already in use. Many companies believe that owning the matching .com version of a business name provides
more protection for their brand than a trademark.</p> </div></div>
</div>
<div class='faq_question faq_q_closed' itemscope itemprop='mainEntity' itemtype='https://schema.org/Question'>
<h3 class='medium' onclick='site_toggle_faq_q(this)' itemprop='name'>Are BrandBucket domain names trademarked?</h3>
<div class='faq_answer' itemscope itemprop='acceptedAnswer' itemtype='https://schema.org/Answer'><div itemprop='text'>
<p>No, and it’s not possible for us to do so. Trademarks are industry and region-specific, and to file a trademark for a name or logo, you must already
be doing business as that name. Because of this, we can't trademark a name before your company is actively using it. Therefore, you will need to apply
for trademark registration after you have purchased the name.</p> </div></div>
</div>
<div class='faq_question faq_q_closed' itemscope itemprop='mainEntity' itemtype='https://schema.org/Question'>
<h3 class='medium' onclick='site_toggle_faq_q(this)' itemprop='name'>Do I have to keep my name registered when I purchase a name from BrandBucket?</h3>
<div class='faq_answer' itemscope itemprop='acceptedAnswer' itemtype='https://schema.org/Answer'><div itemprop='text'>
<p>When you purchase a domain from BrandBucket, you will own it 100%. However, all domain names worldwide must be kept registered at a registrar like
Godaddy or similar that you choose. You will pay the registration fees to whichever registrar you decide to use. The price of registration varies at each
registrar, but it generally ends up being around $10-15 per year for a .com domain name. Registration is annual but can be paid up for years in advance, which
we suggest you do.</p> </div></div>
</div>
<div class='faq_question faq_q_closed' itemscope itemprop='mainEntity' itemtype='https://schema.org/Question'>
<h3 class='medium' onclick='site_toggle_faq_q(this)' itemprop='name'>Does BrandBucket offer refunds?</h3>
<div class='faq_answer' itemscope itemprop='acceptedAnswer' itemtype='https://schema.org/Answer'><div itemprop='text'>
<p>If for whatever reason you decide not to move forward with your purchase, we can accommodate a refund as long as these conditions are met: </p>
<ul>
<li>You contact us within 24 hours of purchase to request a refund.</li>
<li>You have not taken possession of the domain (the domain hasn’t been moved to your registrar account).</li>
</ul> </div></div>
</div>
<div class='faq_question faq_q_closed' itemscope itemprop='mainEntity' itemtype='https://schema.org/Question'>
<h3 class='medium' onclick='site_toggle_faq_q(this)' itemprop='name'>Is my BrandBucket purchase confidential?</h3>
<div class='faq_answer' itemscope itemprop='acceptedAnswer' itemtype='https://schema.org/Answer'><div itemprop='text'>
<p>Your purchase is 100% confidential. Any personal information you share with BrandBucket is kept private, even from the domain seller. We never
publicize any sale on our marketplace. </p> </div></div>
</div>
<div class='faq_question faq_q_closed' itemscope itemprop='mainEntity' itemtype='https://schema.org/Question'>
<h3 class='medium' onclick='site_toggle_faq_q(this)' itemprop='name'>What's the difference between a brand name, registered name, and a domain name?</h3>
<div class='faq_answer' itemscope itemprop='acceptedAnswer' itemtype='https://schema.org/Answer'><div itemprop='text'>
<p><b>Brand Name</b></p>
<p>A brand name is a name that you use to identify a family of products, services, or a single line of products or services that a company offers.
For instance, Apple is the brand name used on most products manufactured by Apple, Inc. In this example, the business name and brand name are the
same, a common use case.</p>
<p>Your brand name is who you are to your customers. It is the pillar your business's public image will be built around. The products or services
you offer can also have their own brand names. You may want to create new brand names for products or services that differ from your core business
offering, for example:</p>
<ul>
<li>UberEats - Food delivery by Uber</li>
<li>Amazon Web Services - Cloud computing from Amazon</li>
<li>Google Maps - Web mapping service from Google</li>
</ul>
<p><b>Registered Business Name</b></p>
<p>A business name is the legally registered name of your business. You'll use your business name to create contracts, open bank accounts, pay taxes,
and any other administrative related activities. Most business names contain the business's brand name, followed by the company's chosen business
structure, for example:</p>
<ul>
<li>Walmart Inc.</li>
<li>Verizon Inc.</li>
<li>Grasshopper LLC</li>
</ul>
<p>However, they don't necessarily have to be the same. In some cases, the business name is completely different from the brand name. This is most
common in large businesses that have multiple brands housed under a single parent company, for example:</p>
<ul>
<li>Brand Name: Google</li>
<li>Business Name: Alphabet Inc.</li>
<li>Brand Name: MailChimp</li>
<li>Business Name: The Rocket Science Group LLC</li>
</ul>
<p><b>Domain Name</b></p>
<p>A domain name is your website name - the internet address where people can access your website. Think of a domain as the address to the online
version of your business. Every domain is one-of-a-kind. No website has the same web address as another website.</p>
<p>Ideally, your domain name should be an exact match to your brand name. Think of your favorite companies. Odds are, their domain name is identical
to their brand name. Apple's domain name is Apple.com; Amazon's domain name is Amazon.com. Having a matching domain ensures that people can easily
find your brand online. </p> </div></div>
</div>
<div class='faq_question faq_q_closed' itemscope itemprop='mainEntity' itemtype='https://schema.org/Question'>
<h3 class='medium' onclick='site_toggle_faq_q(this)' itemprop='name'>What are the benefits of a premium business name?</h3>
<div class='faq_answer' itemscope itemprop='acceptedAnswer' itemtype='https://schema.org/Answer'><div itemprop='text'>
<p>What can a top brand name with a matching .com do for your business? Here are few of the many advantages of owning a premium business domain:</p>
<p><b>Trust</b> - Online, there are subtle clues that all of us subconsciously take into consideration to determine whether or not a business is
legitimate and trustworthy. Having a great business name paired with a matching .com (by far the most trusted domain extension) signals to customers
that you care about and are willing to invest in your brand. It makes your business and your brand messaging easier to trust.</p>
<p><b>Authority</b> - Owning a .com version of a fantastic brand name is a big signal to the world that your business means business, right out of the
gate. This can lead to accelerated customer acquisition, more industry partnership opportunities, and press attention. </p>
<p><b>SEO</b> - Having a business domain that matches what customers are using in searches can lead to increased SEO, higher page ranking, and better
quality traffic. </p>
<p><b>Retention</b> - Brand retention is critical for organically acquiring and keeping customers. A short, catchy, and unique business name makes your
brand easier to remember, and having a matching .com means that consumers who hear about you offline will find you easily online. </p>
<p><b>Save on marketing spend</b> - Investing a premium domain can save you a fortune in marketing spend down the line. You'll spend less of your
valuable marketing budget and efforts on brand awareness, as your name will do much of the work for you. </p> </div></div>
</div>
<div class='faq_question faq_q_closed' itemscope itemprop='mainEntity' itemtype='https://schema.org/Question'>
<h3 class='medium' onclick='site_toggle_faq_q(this)' itemprop='name'>How does BrandBucket price domains?</h3>
<div class='faq_answer' itemscope itemprop='acceptedAnswer' itemtype='https://schema.org/Answer'><div itemprop='text'>
<p>Our customers are primarily entrepreneurs looking for a quick and easy way to find a great brand name for their company. That's why when evaluating
and appraising domain names, our central focus is whether they would also make great business names.</p>
<p>What makes a great brand name? Here are some of the branding and linguistic traits we take into consideration: </p>
<ul>
<li><b>Length</b> - Great names are concise and to the point. The shorter, the better!</li>
<li><b>Common phrase/expression</b> - Names that are based on real phrases and expressions make great brand names because of their built-in familiarity
and inherent catchiness.</li>
<li><b>Letter order</b> - Some letters are more valuable than others and better together, especially when it comes to the first letters of a name.</li>
<li><b>Pronunciation and spelling</b> - Names should be easy to say and understand. It should also be spelled as it sounds.</li>
<li><b>Industry match</b> - Names should be a good fit for a particular industry, or be broad enough to attract buyers from multiple sectors.</li>
<li><b>Longevity</b> - Great brand names are broad enough in scope to grow with a company as it expands and not die when trends fade.</li>
<li><b>Uniqueness</b> - Great brand names are easy to spot because they stand out in a crowd. </li>
<li><b>Memorability</b> - A brand name is no good unless people can easily remember it.</li>
</ul>
<p>These criteria, along with historical sales data and current marketplace conditions, are used to determine whether a name is accepted to our marketplace,
and how it's priced. Every name on our marketplace must score high in most or all of these categories to even be accepted. With an acceptance rate of only
10% of names submitted to our marketplace, BrandBucket sets a very high bar for the names we select. </p> </div></div>
</div>
<div class='h_30'></div>
</div></div>
<script type="text/javascript">
	var m_smartHeader_ID = 1;

function guard_site_smartHeader_resize()
{
	if (typeof site_smartHeader_resize == "function")
	{
		site_smartHeader_resize();
		$(".smart_header_container").css("visibility", "visible");
	} else 
		setTimeout(guard_site_smartHeader_resize, 50);
}

	onLoadFunctions.push( function () {
		var vis = $(".smart_header[background_id="+ m_smartHeader_ID +"]");
		$("body").addClass("smart_landing_page");
		
		if (vis.attr("background_image")) 
			vis.css({
				display: "block",
				backgroundImage: "url(" + vis.attr("background_image") + ")"
			});
		else vis.css({ display: "block" });
		
		guard_site_smartHeader_resize();
	});
</script>
<div class='bk_FF'><div class='content_width center pad_bot_1'>
<div class='h_50'></div>
<div load_url='/related_names?domain=yesharvest.com&source=int&nid=321071' class='theme15_related_iframe'></div>
<div class='h_30'></div>
</div></div>
</div>
<div class='main_list_area'><div class='onload_hidden defa_width'>
<div class='domains_list'>
</div>
<script type='text/javascript'> onLoadFunctions.push( function () {
$('body').addClass('is_landingPage'); gtag('event', 'view_item', {'items': [{ 'id': '321071', 'google_business_vertical': 'custom', 'name': 'yesharvest.com', 'price': '2795', 'brand': 'Keyword', 'category': 'industries/agriculture-farming-business-names', 'category_2': 'industries/food-beverage-business-names',  }]}); }); </script> </div></div>
<script type="text/javascript">function guard_site_pageInitDivs(){if (typeof site_pageInitDivs == "function" && typeof reloadSiteContents == "function"){site_pageInitDivs();$("body").css("visibility","");}else requestAnimationFrame(guard_site_pageInitDivs);}guard_site_pageInitDivs();</script>
<div class='after_list'><div class='bk_EA'><div class='defa_width'><div class='homepage_div transparent_box'><h2 class='large_h1 learn_more_h1 center'>Browse Business Names by Style or Industry</h2><div class='why_brandbucket_text center learn_more_sub'>Find the perfect business name for your industry, sector or style.</div><div class='center font_16'><a href='https://www.brandbucket.com/industries/agriculture-farming-business-names?source=domain' class='category_cloud_box_link' data-category-title='Agriculture & Farming' data-category-alias='agriculture-farming-business-names
							onclick=' return reloadSiteContents({ category: "agriculture-farming-business-names"})'>Agriculture & Farming</a><a href='https://www.brandbucket.com/industries/art-design-business-names?source=domain' class='category_cloud_box_link' data-category-title='Art & Design' data-category-alias='art-design-business-names
							onclick=' return reloadSiteContents({ category: "art-design-business-names"})'>Art & Design</a><a href='https://www.brandbucket.com/styles/catchy-business-names?source=domain' class='category_cloud_box_link' data-category-title='Catchy Names' data-category-alias='catchy-business-names
							onclick=' return reloadSiteContents({ category: "catchy-business-names"})'>Catchy Names</a><a href='https://www.brandbucket.com/industries/charity-nonprofit-business-names?source=domain' class='category_cloud_box_link' data-category-title='Charity & Nonprofit' data-category-alias='charity-nonprofit-business-names
							onclick=' return reloadSiteContents({ category: "charity-nonprofit-business-names"})'>Charity & Nonprofit</a><a href='https://www.brandbucket.com/industries/children-pet-business-names?source=domain' class='category_cloud_box_link' data-category-title='Children & Pets' data-category-alias='children-pet-business-names
							onclick=' return reloadSiteContents({ category: "children-pet-business-names"})'>Children & Pets</a><a href='https://www.brandbucket.com/styles/classic-business-names?source=domain' class='category_cloud_box_link' data-category-title='Classic & Elegant Names' data-category-alias='classic-business-names
							onclick=' return reloadSiteContents({ category: "classic-business-names"})'>Classic & Elegant Names</a><a href='https://www.brandbucket.com/styles/clever-business-names?source=domain' class='category_cloud_box_link' data-category-title='Clever Names' data-category-alias='clever-business-names
							onclick=' return reloadSiteContents({ category: "clever-business-names"})'>Clever Names</a><a href='https://www.brandbucket.com/industries/collaboration-communication-business-names?source=domain' class='category_cloud_box_link font_14' data-category-title='Collaboration & Communication' data-category-alias='collaboration-communication-business-names
							onclick=' return reloadSiteContents({ category: "collaboration-communication-business-names"})'>Collaboration & Communication</a><a href='https://www.brandbucket.com/industries/community-social-business-names?source=domain' class='category_cloud_box_link' data-category-title='Community & Social' data-category-alias='community-social-business-names
							onclick=' return reloadSiteContents({ category: "community-social-business-names"})'>Community & Social</a><a href='https://www.brandbucket.com/industries/consulting-professional-services-business-names?source=domain' class='category_cloud_box_link font_13' data-category-title='Consulting & Professional Services' data-category-alias='consulting-professional-services-business-names
							onclick=' return reloadSiteContents({ category: "consulting-professional-services-business-names"})'>Consulting & Professional Services</a><a href='https://www.brandbucket.com/styles/creative-business-names?source=domain' class='category_cloud_box_link' data-category-title='Creative Business Names' data-category-alias='creative-business-names
							onclick=' return reloadSiteContents({ category: "creative-business-names"})'>Creative Business Names</a><a href='https://www.brandbucket.com/industries/crypto-finance-business-names?source=domain' class='category_cloud_box_link' data-category-title='Crypto & Finance' data-category-alias='crypto-finance-business-names
							onclick=' return reloadSiteContents({ category: "crypto-finance-business-names"})'>Crypto & Finance</a><a href='https://www.brandbucket.com/industries/dating-relationship-business-names?source=domain' class='category_cloud_box_link' data-category-title='Dating & Relationships' data-category-alias='dating-relationship-business-names
							onclick=' return reloadSiteContents({ category: "dating-relationship-business-names"})'>Dating & Relationships</a><a href='https://www.brandbucket.com/industries/education-training-business-names?source=domain' class='category_cloud_box_link' data-category-title='Education & Training' data-category-alias='education-training-business-names
							onclick=' return reloadSiteContents({ category: "education-training-business-names"})'>Education & Training</a><a href='https://www.brandbucket.com/industries/employment-recruitment-business-names?source=domain' class='category_cloud_box_link' data-category-title='Employment & Recruitment' data-category-alias='employment-recruitment-business-names
							onclick=' return reloadSiteContents({ category: "employment-recruitment-business-names"})'>Employment & Recruitment</a><a href='https://www.brandbucket.com/industries/energy-environment-business-names?source=domain' class='category_cloud_box_link' data-category-title='Energy & Environment' data-category-alias='energy-environment-business-names
							onclick=' return reloadSiteContents({ category: "energy-environment-business-names"})'>Energy & Environment</a><a href='https://www.brandbucket.com/industries/event-promotions-business-names?source=domain' class='category_cloud_box_link' data-category-title='Events & Promotions' data-category-alias='event-promotions-business-names
							onclick=' return reloadSiteContents({ category: "event-promotions-business-names"})'>Events & Promotions</a><a href='https://www.brandbucket.com/styles/evocative-business-names?source=domain' class='category_cloud_box_link font_14' data-category-title='Evocative & Suggestive Names' data-category-alias='evocative-business-names
							onclick=' return reloadSiteContents({ category: "evocative-business-names"})'>Evocative & Suggestive Names</a><a href='https://www.brandbucket.com/industries/fashion-beauty-business-names?source=domain' class='category_cloud_box_link' data-category-title='Fashion & Beauty' data-category-alias='fashion-beauty-business-names
							onclick=' return reloadSiteContents({ category: "fashion-beauty-business-names"})'>Fashion & Beauty</a><a href='https://www.brandbucket.com/styles/feminine-business-names?source=domain' class='category_cloud_box_link' data-category-title='Feminine & Female Names' data-category-alias='feminine-business-names
							onclick=' return reloadSiteContents({ category: "feminine-business-names"})'>Feminine & Female Names</a><a href='https://www.brandbucket.com/industries/food-beverage-business-names?source=domain' class='category_cloud_box_link' data-category-title='Food & Beverage' data-category-alias='food-beverage-business-names
							onclick=' return reloadSiteContents({ category: "food-beverage-business-names"})'>Food & Beverage</a><a href='https://www.brandbucket.com/industries/health-wellness-business-names?source=domain' class='category_cloud_box_link' data-category-title='Health & Wellness' data-category-alias='health-wellness-business-names
							onclick=' return reloadSiteContents({ category: "health-wellness-business-names"})'>Health & Wellness</a><a href='https://www.brandbucket.com/industries/innovation-startup-business-names?source=domain' class='category_cloud_box_link' data-category-title='Innovation & Startups' data-category-alias='innovation-startup-business-names
							onclick=' return reloadSiteContents({ category: "innovation-startup-business-names"})'>Innovation & Startups</a><a href='https://www.brandbucket.com/styles/international-global-business-names?source=domain' class='category_cloud_box_link font_14' data-category-title='International & Global Names' data-category-alias='international-global-business-names
							onclick=' return reloadSiteContents({ category: "international-global-business-names"})'>International & Global Names</a><a href='https://www.brandbucket.com/industries/internet-data-business-names?source=domain' class='category_cloud_box_link' data-category-title='Internet & Data' data-category-alias='internet-data-business-names
							onclick=' return reloadSiteContents({ category: "internet-data-business-names"})'>Internet & Data</a><a href='https://www.brandbucket.com/industries/luxury-lifestyle-business-names?source=domain' class='category_cloud_box_link' data-category-title='Luxury & Lifestyle' data-category-alias='luxury-lifestyle-business-names
							onclick=' return reloadSiteContents({ category: "luxury-lifestyle-business-names"})'>Luxury & Lifestyle</a><a href='https://www.brandbucket.com/industries/manufacturing-logistics-business-names?source=domain' class='category_cloud_box_link' data-category-title='Manufacturing & Logistics' data-category-alias='manufacturing-logistics-business-names
							onclick=' return reloadSiteContents({ category: "manufacturing-logistics-business-names"})'>Manufacturing & Logistics</a><a href='https://www.brandbucket.com/styles/masculine-business-names?source=domain' class='category_cloud_box_link' data-category-title='Masculine & Male Names' data-category-alias='masculine-business-names
							onclick=' return reloadSiteContents({ category: "masculine-business-names"})'>Masculine & Male Names</a><a href='https://www.brandbucket.com/industries/mobile-telecom-business-names?source=domain' class='category_cloud_box_link' data-category-title='Mobile & Telecommunication' data-category-alias='mobile-telecom-business-names
							onclick=' return reloadSiteContents({ category: "mobile-telecom-business-names"})'>Mobile & Telecommunication</a><a href='https://www.brandbucket.com/styles/modern-business-names?source=domain' class='category_cloud_box_link' data-category-title='Modern & Trendy Names' data-category-alias='modern-business-names
							onclick=' return reloadSiteContents({ category: "modern-business-names"})'>Modern & Trendy Names</a><a href='https://www.brandbucket.com/industries/multimedia-video-business-names?source=domain' class='category_cloud_box_link' data-category-title='Multimedia & Video' data-category-alias='multimedia-video-business-names
							onclick=' return reloadSiteContents({ category: "multimedia-video-business-names"})'>Multimedia & Video</a><a href='https://www.brandbucket.com/industries/music-and-entertainment-business-names?source=domain' class='category_cloud_box_link' data-category-title='Music & Entertainment' data-category-alias='music-and-entertainment-business-names
							onclick=' return reloadSiteContents({ category: "music-and-entertainment-business-names"})'>Music & Entertainment</a><a href='https://www.brandbucket.com/industries/news-media-business-names?source=domain' class='category_cloud_box_link' data-category-title='News & Media' data-category-alias='news-media-business-names
							onclick=' return reloadSiteContents({ category: "news-media-business-names"})'>News & Media</a><a href='https://www.brandbucket.com/industries/organization-productivity-business-names?source=domain' class='category_cloud_box_link' data-category-title='Organization & Productivity' data-category-alias='organization-productivity-business-names
							onclick=' return reloadSiteContents({ category: "organization-productivity-business-names"})'>Organization & Productivity</a><a href='https://www.brandbucket.com/styles/premium-domain-names?source=domain' class='category_cloud_box_link' data-category-title='Premium Names' data-category-alias='premium-domain-names
							onclick=' return reloadSiteContents({ category: "premium-domain-names"})'>Premium Names</a><a href='https://www.brandbucket.com/industries/real-estate-construction-business-names?source=domain' class='category_cloud_box_link' data-category-title='Real Estate & Construction' data-category-alias='real-estate-construction-business-names
							onclick=' return reloadSiteContents({ category: "real-estate-construction-business-names"})'>Real Estate & Construction</a><a href='https://www.brandbucket.com/industries/retail-ecommerce-business-names?source=domain' class='category_cloud_box_link' data-category-title='Retail & eCommerce' data-category-alias='retail-ecommerce-business-names
							onclick=' return reloadSiteContents({ category: "retail-ecommerce-business-names"})'>Retail & eCommerce</a><a href='https://www.brandbucket.com/industries/sales-marketing-business-names?source=domain' class='category_cloud_box_link' data-category-title='Sales & Marketing' data-category-alias='sales-marketing-business-names
							onclick=' return reloadSiteContents({ category: "sales-marketing-business-names"})'>Sales & Marketing</a><a href='https://www.brandbucket.com/industries/science-medicine-business-names?source=domain' class='category_cloud_box_link' data-category-title='Science & Medicine' data-category-alias='science-medicine-business-names
							onclick=' return reloadSiteContents({ category: "science-medicine-business-names"})'>Science & Medicine</a><a href='https://www.brandbucket.com/industries/search-reference-business-names?source=domain' class='category_cloud_box_link' data-category-title='Search & Reference' data-category-alias='search-reference-business-names
							onclick=' return reloadSiteContents({ category: "search-reference-business-names"})'>Search & Reference</a><a href='https://www.brandbucket.com/industries/security-compliance-business-names?source=domain' class='category_cloud_box_link' data-category-title='Security & Compliance' data-category-alias='security-compliance-business-names
							onclick=' return reloadSiteContents({ category: "security-compliance-business-names"})'>Security & Compliance</a><a href='https://www.brandbucket.com/styles/short-domain-names?source=domain' class='category_cloud_box_link' data-category-title='Short Names' data-category-alias='short-domain-names
							onclick=' return reloadSiteContents({ category: "short-domain-names"})'>Short Names</a><a href='https://www.brandbucket.com/industries/software-technology-business-names?source=domain' class='category_cloud_box_link' data-category-title='Software & Technology' data-category-alias='software-technology-business-names
							onclick=' return reloadSiteContents({ category: "software-technology-business-names"})'>Software & Technology</a><a href='https://www.brandbucket.com/industries/sports-recreation-business-names?source=domain' class='category_cloud_box_link' data-category-title='Sports & Recreation' data-category-alias='sports-recreation-business-names
							onclick=' return reloadSiteContents({ category: "sports-recreation-business-names"})'>Sports & Recreation</a><a href='https://www.brandbucket.com/industries/travel-business-local-business-names?source=domain' class='category_cloud_box_link' data-category-title='Travel & Local' data-category-alias='travel-business-local-business-names
							onclick=' return reloadSiteContents({ category: "travel-business-local-business-names"})'>Travel & Local</a><a href='https://www.brandbucket.com/industries/vehicles-transportation-business-names?source=domain' class='category_cloud_box_link' data-category-title='Vehicles & Transportation' data-category-alias='vehicles-transportation-business-names
							onclick=' return reloadSiteContents({ category: "vehicles-transportation-business-names"})'>Vehicles & Transportation</a></div><div class='clear center pad_top_30 pad_bot_50'><div class='why_brandbucket_text center'><a href='/names' class='round_bluebtn'>Browse all creative business names</a></div></div></div></div></div> <div class='lander-inquire-bk' onclick='site_lander_hide_inquire()'></div>
<div class='lander-inquire-form bk_EA'>
<div class='lander-inquire-close' onclick='site_lander_hide_inquire()'><img src="/images6/icon_bc_remove.png" alt="Close dialog" /></div>
<div class='domain-enquire' style='display: none;' must_load=1>
</div>
</div>
</div>
</div>
<div class='move_elements d_none'>
<div target='browse_by_style'><div><div class='browse_by_shadow_inner'>
<a href='#' onclick='return site_hideCategoryCloud()' class='close_btn'><img src='/images6/icon_bc_remove_wh.png' alt='Remove' /></a>
<h3 class='medium'>Browse business names by style</h3>
<table width='50%' class='rearange_in_columns' min_rows='9' col_width='200'><tbody><tr valign='top'><td>
<a href='https://www.brandbucket.com/styles/premium-domain-names' onclick='return reloadSiteContents({category: "premium-domain-names", clear: true});'><span>Premium Names</span></a>
<a href='https://www.brandbucket.com/styles/short-domain-names' onclick='return reloadSiteContents({category: "short-domain-names", clear: true});'><span>Short Names</span></a>
<a href='https://www.brandbucket.com/styles/catchy-business-names' onclick='return reloadSiteContents({category: "catchy-business-names", clear: true});'><span>Catchy Names</span></a>
<a href='https://www.brandbucket.com/styles/clever-business-names' onclick='return reloadSiteContents({category: "clever-business-names", clear: true});'><span>Clever Names</span></a>
<a href='https://www.brandbucket.com/styles/classic-business-names' onclick='return reloadSiteContents({category: "classic-business-names", clear: true});'><span>Classic &amp; Elegant Names</span></a>
<a href='https://www.brandbucket.com/styles/modern-business-names' onclick='return reloadSiteContents({category: "modern-business-names", clear: true});'><span>Modern &amp; Trendy Names</span></a>
<a href='https://www.brandbucket.com/styles/international-global-business-names' onclick='return reloadSiteContents({category: "international-global-business-names", clear: true});'><span>International &amp; Global Names</span></a>
<a href='https://www.brandbucket.com/styles/creative-business-names' onclick='return reloadSiteContents({category: "creative-business-names", clear: true});'><span>Creative Business Names</span></a>
<a href='https://www.brandbucket.com/styles/evocative-business-names' onclick='return reloadSiteContents({category: "evocative-business-names", clear: true});'><span>Evocative &amp; Suggestive Names</span></a>
<a href='https://www.brandbucket.com/styles/feminine-business-names' onclick='return reloadSiteContents({category: "feminine-business-names", clear: true});'><span>Feminine &amp; Female Names</span></a>
<a href='https://www.brandbucket.com/styles/masculine-business-names' onclick='return reloadSiteContents({category: "masculine-business-names", clear: true});'><span>Masculine &amp; Male Names</span></a>
</td></tr></tbody></table>
</div></div></div>
<div target='browse_by_industry'><div><div class='browse_by_shadow_inner'>
<a href='#' onclick='return site_hideCategoryCloud()' class='close_btn'><img src='/images6/icon_bc_remove_wh.png' alt='Remove' /></a>
<h3 class='medium'>Browse business names by industry</h3>
<table width='100%' class='rearange_in_columns' min_rows='9' col_width='200'><tbody><tr valign='top'><td>
<a href='https://www.brandbucket.com/industries/agriculture-farming-business-names' onclick='return reloadSiteContents({category: "agriculture-farming-business-names", clear: true});'><span>Agriculture &amp; Farming</span></a>
<a href='https://www.brandbucket.com/industries/art-design-business-names' onclick='return reloadSiteContents({category: "art-design-business-names", clear: true});'><span>Art &amp; Design</span></a>
<a href='https://www.brandbucket.com/industries/charity-nonprofit-business-names' onclick='return reloadSiteContents({category: "charity-nonprofit-business-names", clear: true});'><span>Charity &amp; Nonprofit</span></a>
<a href='https://www.brandbucket.com/industries/children-pet-business-names' onclick='return reloadSiteContents({category: "children-pet-business-names", clear: true});'><span>Children &amp; Pets</span></a>
<a href='https://www.brandbucket.com/industries/collaboration-communication-business-names' onclick='return reloadSiteContents({category: "collaboration-communication-business-names", clear: true});'><span>Collaboration &amp; Communication</span></a>
<a href='https://www.brandbucket.com/industries/community-social-business-names' onclick='return reloadSiteContents({category: "community-social-business-names", clear: true});'><span>Community &amp; Social</span></a>
<a href='https://www.brandbucket.com/industries/consulting-professional-services-business-names' onclick='return reloadSiteContents({category: "consulting-professional-services-business-names", clear: true});'><span>Consulting &amp; Professional Services</span></a>
<a href='https://www.brandbucket.com/industries/crypto-finance-business-names' onclick='return reloadSiteContents({category: "crypto-finance-business-names", clear: true});'><span>Crypto &amp; Finance</span></a>
<a href='https://www.brandbucket.com/industries/dating-relationship-business-names' onclick='return reloadSiteContents({category: "dating-relationship-business-names", clear: true});'><span>Dating &amp; Relationships</span></a>
<a href='https://www.brandbucket.com/industries/education-training-business-names' onclick='return reloadSiteContents({category: "education-training-business-names", clear: true});'><span>Education &amp; Training</span></a>
<a href='https://www.brandbucket.com/industries/employment-recruitment-business-names' onclick='return reloadSiteContents({category: "employment-recruitment-business-names", clear: true});'><span>Employment &amp; Recruitment</span></a>
<a href='https://www.brandbucket.com/industries/energy-environment-business-names' onclick='return reloadSiteContents({category: "energy-environment-business-names", clear: true});'><span>Energy &amp; Environment</span></a>
<a href='https://www.brandbucket.com/industries/event-promotions-business-names' onclick='return reloadSiteContents({category: "event-promotions-business-names", clear: true});'><span>Events &amp; Promotions</span></a>
<a href='https://www.brandbucket.com/industries/fashion-beauty-business-names' onclick='return reloadSiteContents({category: "fashion-beauty-business-names", clear: true});'><span>Fashion &amp; Beauty</span></a>
<a href='https://www.brandbucket.com/industries/food-beverage-business-names' onclick='return reloadSiteContents({category: "food-beverage-business-names", clear: true});'><span>Food &amp; Beverage</span></a>
<a href='https://www.brandbucket.com/industries/health-wellness-business-names' onclick='return reloadSiteContents({category: "health-wellness-business-names", clear: true});'><span>Health &amp; Wellness</span></a>
<a href='https://www.brandbucket.com/industries/innovation-startup-business-names' onclick='return reloadSiteContents({category: "innovation-startup-business-names", clear: true});'><span>Innovation &amp; Startups</span></a>
<a href='https://www.brandbucket.com/industries/internet-data-business-names' onclick='return reloadSiteContents({category: "internet-data-business-names", clear: true});'><span>Internet &amp; Data</span></a>
<a href='https://www.brandbucket.com/industries/luxury-lifestyle-business-names' onclick='return reloadSiteContents({category: "luxury-lifestyle-business-names", clear: true});'><span>Luxury &amp; Lifestyle</span></a>
<a href='https://www.brandbucket.com/industries/manufacturing-logistics-business-names' onclick='return reloadSiteContents({category: "manufacturing-logistics-business-names", clear: true});'><span>Manufacturing &amp; Logistics</span></a>
<a href='https://www.brandbucket.com/industries/mobile-telecom-business-names' onclick='return reloadSiteContents({category: "mobile-telecom-business-names", clear: true});'><span>Mobile &amp; Telecommunication</span></a>
<a href='https://www.brandbucket.com/industries/multimedia-video-business-names' onclick='return reloadSiteContents({category: "multimedia-video-business-names", clear: true});'><span>Multimedia &amp; Video</span></a>
<a href='https://www.brandbucket.com/industries/music-and-entertainment-business-names' onclick='return reloadSiteContents({category: "music-and-entertainment-business-names", clear: true});'><span>Music &amp; Entertainment</span></a>
<a href='https://www.brandbucket.com/industries/news-media-business-names' onclick='return reloadSiteContents({category: "news-media-business-names", clear: true});'><span>News &amp; Media</span></a>
<a href='https://www.brandbucket.com/industries/organization-productivity-business-names' onclick='return reloadSiteContents({category: "organization-productivity-business-names", clear: true});'><span>Organization &amp; Productivity</span></a>
<a href='https://www.brandbucket.com/industries/real-estate-construction-business-names' onclick='return reloadSiteContents({category: "real-estate-construction-business-names", clear: true});'><span>Real Estate &amp; Construction</span></a>
<a href='https://www.brandbucket.com/industries/retail-ecommerce-business-names' onclick='return reloadSiteContents({category: "retail-ecommerce-business-names", clear: true});'><span>Retail &amp; eCommerce</span></a>
<a href='https://www.brandbucket.com/industries/sales-marketing-business-names' onclick='return reloadSiteContents({category: "sales-marketing-business-names", clear: true});'><span>Sales &amp; Marketing</span></a>
<a href='https://www.brandbucket.com/industries/science-medicine-business-names' onclick='return reloadSiteContents({category: "science-medicine-business-names", clear: true});'><span>Science &amp; Medicine</span></a>
<a href='https://www.brandbucket.com/industries/search-reference-business-names' onclick='return reloadSiteContents({category: "search-reference-business-names", clear: true});'><span>Search &amp; Reference</span></a>
<a href='https://www.brandbucket.com/industries/security-compliance-business-names' onclick='return reloadSiteContents({category: "security-compliance-business-names", clear: true});'><span>Security &amp; Compliance</span></a>
<a href='https://www.brandbucket.com/industries/software-technology-business-names' onclick='return reloadSiteContents({category: "software-technology-business-names", clear: true});'><span>Software &amp; Technology</span></a>
<a href='https://www.brandbucket.com/industries/sports-recreation-business-names' onclick='return reloadSiteContents({category: "sports-recreation-business-names", clear: true});'><span>Sports &amp; Recreation</span></a>
<a href='https://www.brandbucket.com/industries/travel-business-local-business-names' onclick='return reloadSiteContents({category: "travel-business-local-business-names", clear: true});'><span>Travel &amp; Local</span></a>
<a href='https://www.brandbucket.com/industries/vehicles-transportation-business-names' onclick='return reloadSiteContents({category: "vehicles-transportation-business-names", clear: true});'><span>Vehicles &amp; Transportation</span></a>
</td></tr></tbody></table>
</div></div></div>
<div target='browse_resources'><div><div class='browse_by_shadow_inner'>
<a href='#' onclick='return site_hideCategoryCloud()' class='close_btn'><img src='/images6/icon_bc_remove_wh.png' alt='Remove' /></a>
<table width='100%'><tbody><tr valign='top'><td>
<h3 class='medium'>Business Names 101</h3><a href='/resources/what-makes-a-great-business-name' onclick='return reloadSiteContents("/resources/what-makes-a-great-business-name")'><span>What makes a great business name?</span></a><a href='/resources/how-do-i-choose-the-right-name-for-my-business' onclick='return reloadSiteContents("/resources/how-do-i-choose-the-right-name-for-my-business")'><span>How to name your business</span></a><a href='/resources/what-is-the-best-tld-for-a-business-domain-name' onclick='return reloadSiteContents("/resources/what-is-the-best-tld-for-a-business-domain-name")'><span>What is the best tld for a business domain name?</span></a><a href='/resources/why-is-pronunciation-important-for-a-business-name' onclick='return reloadSiteContents("/resources/why-is-pronunciation-important-for-a-business-name")'><span>How important is pronunciation for a business name?</span></a><a href='/resources/how-to-avoid-conflicts-when-choosing-a-business-name' onclick='return reloadSiteContents("/resources/how-to-avoid-conflicts-when-choosing-a-business-name")'><span>How to avoid business name conflicts</span></a><a href='/resources/how-to-choose-a-unique-business-name' onclick='return reloadSiteContents("/resources/how-to-choose-a-unique-business-name")'><span>How to choose a unique business name</span></a><a href='/resources/why-choose-a-business-name-with-longevity' onclick='return reloadSiteContents("/resources/why-choose-a-business-name-with-longevity")'><span>Why does business name longevity matter?</span></a><a href='/resources/what-is-the-best-length-for-a-business-name' onclick='return reloadSiteContents("/resources/what-is-the-best-length-for-a-business-name")'><span>What is the best length for a business name?</span></a><a href='/resources/why-are-some-letters-more-common-in-business-names' onclick='return reloadSiteContents("/resources/why-are-some-letters-more-common-in-business-names")'><span>What are the most common letters used in business names?</span></a><a href='/resources/which-type-of-business-name-is-best-for-your-business' onclick='return reloadSiteContents("/resources/which-type-of-business-name-is-best-for-your-business")'><span>Which type of business name is best for your business?</span></a><a href='/resources/how-does-spelling-affect-your-business-name' onclick='return reloadSiteContents("/resources/how-does-spelling-affect-your-business-name")'><span>How does domain name spelling affect your business?</span></a><a href='/resources/can-real-words-and-expressions-be-good-business-names' onclick='return reloadSiteContents("/resources/can-real-words-and-expressions-be-good-business-names")'><span>Can real words and expressions be good business names?</span></a><a href='/resources/how-to-choose-a-business-name-with-great-retention' onclick='return reloadSiteContents("/resources/how-to-choose-a-business-name-with-great-retention")'><span>Why you should consider retention when choosing a name for your business</span></a><a href='/resources/why-business-name-generators-dont-work' onclick='return reloadSiteContents("/resources/why-business-name-generators-dont-work")'><span>Why business name generators don’t work</span></a><a href='/resources/10-tips-for-creating-a-catchy-business-name' onclick='return reloadSiteContents("/resources/10-tips-for-creating-a-catchy-business-name")'><span>10 tips for creating a catchy business name</span></a></td><td><h3 class='medium'>Domain Names 101</h3><a href='/resources/what-is-a-domain-name' onclick='return reloadSiteContents("/resources/what-is-a-domain-name")'><span>What is a domain name?</span></a><a href='/resources/what-is-a-domain-name-registrar' onclick='return reloadSiteContents("/resources/what-is-a-domain-name-registrar")'><span>What is a domain name registrar?</span></a><a href='/resources/what-is-a-premium-domain-name' onclick='return reloadSiteContents("/resources/what-is-a-premium-domain-name")'><span>What is a premium domain name?</span></a><a href='/resources/what-is-a-brandable-domain-name' onclick='return reloadSiteContents("/resources/what-is-a-brandable-domain-name")'><span>What is a brandable domain name?</span></a><a href='/resources/why-a-com-domain-name-is-the-best-option' onclick='return reloadSiteContents("/resources/why-a-com-domain-name-is-the-best-option")'><span>Why is a .com domain name is the best option?</span></a><a href='/resources/difference-between-business-names-brand-names-and-domain-names' onclick='return reloadSiteContents("/resources/difference-between-business-names-brand-names-and-domain-names")'><span>Difference between business names, brand names and domain names</span></a><div class='h_30 clear'></div><h3 class='medium'>Lean Branding 101</h3><a href='/resources/what-is-a-lean-startup' onclick='return reloadSiteContents("/resources/what-is-a-lean-startup")'><span>What is a lean startup?</span></a><a href='/resources/how-to-apply-the-lean-startup-methodology' onclick='return reloadSiteContents("/resources/how-to-apply-the-lean-startup-methodology")'><span>How to apply the lean startup methodology</span></a><a href='/resources/what-is-lean-branding' onclick='return reloadSiteContents("/resources/what-is-lean-branding")'><span>What is lean branding?</span></a><a href='/resources/how-to-apply-lean-branding-to-business-naming' onclick='return reloadSiteContents("/resources/how-to-apply-lean-branding-to-business-naming")'><span>How to apply lean branding to business naming?</span></a><a href='/resources/how-to-brainstorm-domain-names-the-lean-way' onclick='return reloadSiteContents("/resources/how-to-brainstorm-domain-names-the-lean-way")'><span>How to brainstorm domains the lean way</span></a><div class='h_30 clear'></div><h3 class='medium'>Business Name Trends</h3><a href='/resources/top-cannabis-business-names' onclick='return reloadSiteContents("/resources/top-cannabis-business-names")'><span>Top cannabis business names</span></a> </td></tr></tbody></table>
</div></div></div>
<div target='browse_faq'><div><div class='browse_by_shadow_inner'>
<a href='#' onclick='return site_hideCategoryCloud()' class='close_btn'><img src='/images6/icon_bc_remove_wh.png' alt='Remove' /></a>
<table width='100%'><tbody><tr valign='top'><td>
<h3 class='medium'>How BrandBucket Works</h3><a href='/faq/why-use-brandbucket-to-find-a-business-name' onclick='return reloadSiteContents("/faq/why-use-brandbucket-to-find-a-business-name")'><span>Why use BrandBucket to find a business name?</span></a><a href='/faq/who-are-brandbucket-customers' onclick='return reloadSiteContents("/faq/who-are-brandbucket-customers")'><span>Who are BrandBucket customers?</span></a><a href='/faq/who-are-the-people-behind-brandbucket' onclick='return reloadSiteContents("/faq/who-are-the-people-behind-brandbucket")'><span>Who are the people behind BrandBucket?</span></a><a href='/faq/how-does-brandbucket-curate-its-names' onclick='return reloadSiteContents("/faq/how-does-brandbucket-curate-its-names")'><span>How does BrandBucket curate its names?</span></a><a href='/faq/how-do-i-find-a-name-on-brandbucket' onclick='return reloadSiteContents("/faq/how-do-i-find-a-name-on-brandbucket")'><span>How do I find a name on BrandBucket?</span></a><a href='/faq/what-type-of-names-will-i-find-on-brandbucket' onclick='return reloadSiteContents("/faq/what-type-of-names-will-i-find-on-brandbucket")'><span>What type of names will I find on BrandBucket?</span></a><a href='/faq/what-domain-extensions-does-brandbucket-offer' onclick='return reloadSiteContents("/faq/what-domain-extensions-does-brandbucket-offer")'><span>What domain extensions does BrandBucket offer?</span></a><a href='/faq/what-do-i-get-when-i-buy-a-name-from-brandbucket' onclick='return reloadSiteContents("/faq/what-do-i-get-when-i-buy-a-name-from-brandbucket")'><span>What do I get when I buy a name from BrandBucket?</span></a><a href='/faq/does-my-brandbucket-name-come-with-a-trademark' onclick='return reloadSiteContents("/faq/does-my-brandbucket-name-come-with-a-trademark")'><span>Does my BrandBucket name come with a trademark?</span></a><a href='/faq/how-do-i-buy-a-name-on-brandbucket' onclick='return reloadSiteContents("/faq/how-do-i-buy-a-name-on-brandbucket")'><span>How do I buy a name on BrandBucket?</span></a><a href='/faq/what-happens-after-i-buy-a-name-from-brandbucket' onclick='return reloadSiteContents("/faq/what-happens-after-i-buy-a-name-from-brandbucket")'><span>What happens after I buy a name from BrandBucket?</span></a><a href='/faq/what-is-brandbuckets-refund-policy' onclick='return reloadSiteContents("/faq/what-is-brandbuckets-refund-policy")'><span>What is BrandBucket's refund policy?</span></a> </td></tr></tbody></table>
</div></div></div>
</div>
<div class='footer'>
<div class='defa_width darkerback2'>
<div class='footerdiv footer_1'>
<span class='bigger'>Quick Links</span><br />
<a href='/'><span>Home</span></a>
<a href='/names'><span>Names</span></a>
<a href='/about'><span>About</span></a>
<a href='/terms-use'><span>Terms</span></a>
<a href='/privacy-policy'><span>Privacy</span></a>
<a href='/domain-owners' class='force_reload'><span>Sellers</span></a>
<a href='/user' class='force_reload' rel='nofollow'><span>Login</span></a>
</div>
<div class='footerdiv footer_2 only_desktop'>
<span class='bigger'>Resources</span><br />
<a href='/business-names'><span>Business Names</span></a>
<a href='/company-names'><span>Company Names</span></a>
<a href='/domain-names'><span>Domain Names</span></a>
<a href='/website-names'><span>Website Names</span></a>
<a href='/product-names'><span>Product Names</span></a>
<a href='/application-names'><span>Application Names</span></a>
</div>
<div class='footerdiv sigup_text footer_4 only_desktop'>
<span class='bigger'>Want More Options?</span><br />
Subscribe to our weekly digest of new names.
<form onsubmit="return site_processSubscribeForm(this, 'Footer')" method="post" action="/">
<input type="email" name="my_mail" id="footer_signup_my_email" placeholder="Email address" />
<label for="footer_signup_my_email">
<input type="submit" value="Sign up" class="submit_button" />
</label>
</form>
</div>
<div class='footerdiv footer_5'>
<span class='bigger only_desktop'>Contact</span><br />
<div class='contact_links'>
<a href='tel:+13233930684' onclick='site_sendEvent("PhoneCall", "PhoneClick", "Footer")' itemscope itemtype="http://schema.org/Organization"><span itemprop='telephone'>+1 (323) 393-0684</span></a>
<a href='mailto:sales@brandbucket.com'><span>sales@brandbucket.com</span></a>
<a href='mailto:info@brandbucket.com' class='only_desktop'><span>info@brandbucket.com</span></a>
<a href='https://brandbucket.setster.com/' onclick='return site_setster_widget_show();'><span>Book a free consultation</span></a>
</div>
<div class='social_icons only_desktop'>
<a href='https://twitter.com/brandbucket' target='_blank' rel='noopener'><img src='/images/social/32_wh_sprite.png' alt='Twitter' style='object-position: -96px -32px' /></a>
<a href='https://www.facebook.com/brandbucket' target='_blank' rel='noopener'><img src='/images/social/32_wh_sprite.png' alt='Facebook' /></a>
<a href='https://www.instagram.com/brandbucket/' target='_blank' rel='noopener'><img src='/images/social/32_wh_sprite.png' alt='Instagram' style='object-position: -64px -64px' /></a>
<a href='https://www.linkedin.com/company/BrandBucket' target='_blank' rel='noopener'><img src='/images/social/32_wh_sprite.png' alt='LinkedIn' style='object-position: -64px 0' /></a>
<a href='https://www.youtube.com/BrandBucket' target='_blank' rel='noopener'><img src='/images/social/32_wh_sprite.png' alt='YouTube' style='object-position: -32px -64px' /></a>
</div>
</div>
<div class='clear'></div><div class='footer_sep'></div>
<div class='copyright'>
&copy; 2007-2020 BrandBucket.com a <a href='https://www.boxador.com/' rel='noopener' target='_blank'>Boxador</a>&nbsp;production.
</div>
</div>
</div>
</div>
<div class='page_contents_over'></div>
<div class='page_left_menu_holder'>
<div class="left_menu_search"><form id='search_left_menu' onsubmit="$('.page_contents_over').trigger('click');return reloadSiteContents({q:$('#search_left_menu input[name=keyword]').val(),trigger_GA_event:true});" action=""><label for='search_left_menu_edit'><input type='submit' value='Search Business Names' /></label><input type='text' id='search_left_menu_edit' name='keyword' value="" /></form></div>
<div class='left_menu_panel left_menu_panel_main darkerback2'>
<div class='left_menu_big_links'>
<a href='/' class='menu_icon_home'><span>Home</span></a>
<div class='spacer'></div>
<a href='/names' class='menu_icon_content'><span>All names</span></a>
<a href='#' class='menu_icon_content' onclick='return site_leftMenu_showPanel("styles", -1)'><span>By style</span><b class='menu_link_openmore'></b></a>
<a href='#' class='menu_icon_content' onclick='return site_leftMenu_showPanel("industries", -1)'><span>By industry</span><b class='menu_link_openmore'></b></a>
<div class='spacer'></div>
<a href='#' class='menu_icon_story' onclick='return site_leftMenu_showPanel("resources", -1)'><span>Resources</span><b class='menu_link_openmore'></b></a>
<a href='#' class='menu_icon_story' onclick='return site_leftMenu_showPanel("faq", -1)'><span>FAQ</span><b class='menu_link_openmore'></b></a>
<div class='spacer'></div>
<a href='/about' class='menu_icon_content'><span>About</span></a>
<a href='/terms-use' class='menu_icon_content'><span>Terms</span></a>
<a href='/privacy-policy' class='menu_icon_content'><span>Privacy</span></a>
<div class='spacer'></div>
<a href='/domain-owners' class='force_reload menu_icon_faq'><span>Sellers</span></a>
<div class='spacer'></div>
<a href='/user' class='force_reload menu_icon_clients' rel='nofollow'><span>Login</span></a>
<div class='spacer'></div>
</div>
<div class='left_menu_big_links'>
<b>Contact</b><div class='h_25'></div>
<a href='tel:+13233930684' class='menu_icon_phone' onclick='site_sendEvent("PhoneCall", "PhoneClick", "LeftMenu")'><span>+1 (323) 393-0684</span></a>
<a href='mailto:info@brandbucket.com' class='menu_icon_mail'><span>info@brandbucket.com</span></a>
<a href='mailto:sales@brandbucket.com' class='menu_icon_mail'><span>sales@brandbucket.com</span></a>
<div class='spacer'></div>
</div>
<div class='left_menu_big_links signup_form'>
SIGNUP TO OUR MAILING LIST
<div class='left_menu_search'>
<form onsubmit="return site_processSubscribeForm(this, 'LeftMenu')" method="post" action="/">
<input type="submit" id="left_menu_signup_my_email" value="Sign up" class="submit_button" />
<label for="left_menu_signup_my_email" class="d_none">Signup to BrandBucket's newsletter</label>
<input type="email" name="my_mail" class="default_value" placeholder="Email" />
</form>
</div>
</div>
<div class='h_30'></div>
</div>
<div class='left_menu_panel left_menu_panel_styles darkerback2'>
<div class='left_menu_big_links'>
<a href='#' onclick='return site_leftMenu_showPanel("main", 1);' class='menu_link_return'><span>Back</span></a>
<a href='https://www.brandbucket.com/styles/premium-domain-names' onclick='return reloadSiteContents({category: "premium-domain-names", clear: true});'><span>Premium Names</span></a>
<a href='https://www.brandbucket.com/styles/short-domain-names' onclick='return reloadSiteContents({category: "short-domain-names", clear: true});'><span>Short Names</span></a>
<a href='https://www.brandbucket.com/styles/catchy-business-names' onclick='return reloadSiteContents({category: "catchy-business-names", clear: true});'><span>Catchy Names</span></a>
<a href='https://www.brandbucket.com/styles/clever-business-names' onclick='return reloadSiteContents({category: "clever-business-names", clear: true});'><span>Clever Names</span></a>
<a href='https://www.brandbucket.com/styles/classic-business-names' onclick='return reloadSiteContents({category: "classic-business-names", clear: true});'><span>Classic &amp; Elegant Names</span></a>
<a href='https://www.brandbucket.com/styles/modern-business-names' onclick='return reloadSiteContents({category: "modern-business-names", clear: true});'><span>Modern &amp; Trendy Names</span></a>
<a href='https://www.brandbucket.com/styles/international-global-business-names' onclick='return reloadSiteContents({category: "international-global-business-names", clear: true});'><span>International &amp; Global Names</span></a>
<a href='https://www.brandbucket.com/styles/creative-business-names' onclick='return reloadSiteContents({category: "creative-business-names", clear: true});'><span>Creative Business Names</span></a>
<a href='https://www.brandbucket.com/styles/evocative-business-names' onclick='return reloadSiteContents({category: "evocative-business-names", clear: true});'><span>Evocative &amp; Suggestive Names</span></a>
<a href='https://www.brandbucket.com/styles/feminine-business-names' onclick='return reloadSiteContents({category: "feminine-business-names", clear: true});'><span>Feminine &amp; Female Names</span></a>
<a href='https://www.brandbucket.com/styles/masculine-business-names' onclick='return reloadSiteContents({category: "masculine-business-names", clear: true});'><span>Masculine &amp; Male Names</span></a>
</div>
<div class='h_30'></div>
</div>
<div class='left_menu_panel left_menu_panel_industries darkerback2'>
<div class='left_menu_big_links'>
<a href='#' onclick='return site_leftMenu_showPanel("main", 1);' class='menu_link_return'><span>Back</span></a>
<a href='https://www.brandbucket.com/industries/agriculture-farming-business-names' onclick='return reloadSiteContents({category: "agriculture-farming-business-names", clear: true});'><span>Agriculture &amp; Farming</span></a>
<a href='https://www.brandbucket.com/industries/art-design-business-names' onclick='return reloadSiteContents({category: "art-design-business-names", clear: true});'><span>Art &amp; Design</span></a>
<a href='https://www.brandbucket.com/industries/charity-nonprofit-business-names' onclick='return reloadSiteContents({category: "charity-nonprofit-business-names", clear: true});'><span>Charity &amp; Nonprofit</span></a>
<a href='https://www.brandbucket.com/industries/children-pet-business-names' onclick='return reloadSiteContents({category: "children-pet-business-names", clear: true});'><span>Children &amp; Pets</span></a>
<a href='https://www.brandbucket.com/industries/collaboration-communication-business-names' onclick='return reloadSiteContents({category: "collaboration-communication-business-names", clear: true});'><span>Collaboration &amp; Communication</span></a>
<a href='https://www.brandbucket.com/industries/community-social-business-names' onclick='return reloadSiteContents({category: "community-social-business-names", clear: true});'><span>Community &amp; Social</span></a>
<a href='https://www.brandbucket.com/industries/consulting-professional-services-business-names' onclick='return reloadSiteContents({category: "consulting-professional-services-business-names", clear: true});'><span>Consulting &amp; Professional Services</span></a>
<a href='https://www.brandbucket.com/industries/crypto-finance-business-names' onclick='return reloadSiteContents({category: "crypto-finance-business-names", clear: true});'><span>Crypto &amp; Finance</span></a>
<a href='https://www.brandbucket.com/industries/dating-relationship-business-names' onclick='return reloadSiteContents({category: "dating-relationship-business-names", clear: true});'><span>Dating &amp; Relationships</span></a>
<a href='https://www.brandbucket.com/industries/education-training-business-names' onclick='return reloadSiteContents({category: "education-training-business-names", clear: true});'><span>Education &amp; Training</span></a>
<a href='https://www.brandbucket.com/industries/employment-recruitment-business-names' onclick='return reloadSiteContents({category: "employment-recruitment-business-names", clear: true});'><span>Employment &amp; Recruitment</span></a>
<a href='https://www.brandbucket.com/industries/energy-environment-business-names' onclick='return reloadSiteContents({category: "energy-environment-business-names", clear: true});'><span>Energy &amp; Environment</span></a>
<a href='https://www.brandbucket.com/industries/event-promotions-business-names' onclick='return reloadSiteContents({category: "event-promotions-business-names", clear: true});'><span>Events &amp; Promotions</span></a>
<a href='https://www.brandbucket.com/industries/fashion-beauty-business-names' onclick='return reloadSiteContents({category: "fashion-beauty-business-names", clear: true});'><span>Fashion &amp; Beauty</span></a>
<a href='https://www.brandbucket.com/industries/food-beverage-business-names' onclick='return reloadSiteContents({category: "food-beverage-business-names", clear: true});'><span>Food &amp; Beverage</span></a>
<a href='https://www.brandbucket.com/industries/health-wellness-business-names' onclick='return reloadSiteContents({category: "health-wellness-business-names", clear: true});'><span>Health &amp; Wellness</span></a>
<a href='https://www.brandbucket.com/industries/innovation-startup-business-names' onclick='return reloadSiteContents({category: "innovation-startup-business-names", clear: true});'><span>Innovation &amp; Startups</span></a>
<a href='https://www.brandbucket.com/industries/internet-data-business-names' onclick='return reloadSiteContents({category: "internet-data-business-names", clear: true});'><span>Internet &amp; Data</span></a>
<a href='https://www.brandbucket.com/industries/luxury-lifestyle-business-names' onclick='return reloadSiteContents({category: "luxury-lifestyle-business-names", clear: true});'><span>Luxury &amp; Lifestyle</span></a>
<a href='https://www.brandbucket.com/industries/manufacturing-logistics-business-names' onclick='return reloadSiteContents({category: "manufacturing-logistics-business-names", clear: true});'><span>Manufacturing &amp; Logistics</span></a>
<a href='https://www.brandbucket.com/industries/mobile-telecom-business-names' onclick='return reloadSiteContents({category: "mobile-telecom-business-names", clear: true});'><span>Mobile &amp; Telecommunication</span></a>
<a href='https://www.brandbucket.com/industries/multimedia-video-business-names' onclick='return reloadSiteContents({category: "multimedia-video-business-names", clear: true});'><span>Multimedia &amp; Video</span></a>
<a href='https://www.brandbucket.com/industries/music-and-entertainment-business-names' onclick='return reloadSiteContents({category: "music-and-entertainment-business-names", clear: true});'><span>Music &amp; Entertainment</span></a>
<a href='https://www.brandbucket.com/industries/news-media-business-names' onclick='return reloadSiteContents({category: "news-media-business-names", clear: true});'><span>News &amp; Media</span></a>
<a href='https://www.brandbucket.com/industries/organization-productivity-business-names' onclick='return reloadSiteContents({category: "organization-productivity-business-names", clear: true});'><span>Organization &amp; Productivity</span></a>
<a href='https://www.brandbucket.com/industries/real-estate-construction-business-names' onclick='return reloadSiteContents({category: "real-estate-construction-business-names", clear: true});'><span>Real Estate &amp; Construction</span></a>
<a href='https://www.brandbucket.com/industries/retail-ecommerce-business-names' onclick='return reloadSiteContents({category: "retail-ecommerce-business-names", clear: true});'><span>Retail &amp; eCommerce</span></a>
<a href='https://www.brandbucket.com/industries/sales-marketing-business-names' onclick='return reloadSiteContents({category: "sales-marketing-business-names", clear: true});'><span>Sales &amp; Marketing</span></a>
<a href='https://www.brandbucket.com/industries/science-medicine-business-names' onclick='return reloadSiteContents({category: "science-medicine-business-names", clear: true});'><span>Science &amp; Medicine</span></a>
<a href='https://www.brandbucket.com/industries/search-reference-business-names' onclick='return reloadSiteContents({category: "search-reference-business-names", clear: true});'><span>Search &amp; Reference</span></a>
<a href='https://www.brandbucket.com/industries/security-compliance-business-names' onclick='return reloadSiteContents({category: "security-compliance-business-names", clear: true});'><span>Security &amp; Compliance</span></a>
<a href='https://www.brandbucket.com/industries/software-technology-business-names' onclick='return reloadSiteContents({category: "software-technology-business-names", clear: true});'><span>Software &amp; Technology</span></a>
<a href='https://www.brandbucket.com/industries/sports-recreation-business-names' onclick='return reloadSiteContents({category: "sports-recreation-business-names", clear: true});'><span>Sports &amp; Recreation</span></a>
<a href='https://www.brandbucket.com/industries/travel-business-local-business-names' onclick='return reloadSiteContents({category: "travel-business-local-business-names", clear: true});'><span>Travel &amp; Local</span></a>
<a href='https://www.brandbucket.com/industries/vehicles-transportation-business-names' onclick='return reloadSiteContents({category: "vehicles-transportation-business-names", clear: true});'><span>Vehicles &amp; Transportation</span></a>
</div>
<div class='h_30'></div>
</div>
<div class='left_menu_panel left_menu_panel_resources darkerback2'>
<div class='left_menu_big_links'>
<a href='#' onclick='return site_leftMenu_showPanel("main", 1);' class='menu_link_return'><span>Back</span></a>
<strong>Business Names 101</strong><a href='https://www.brandbucket.com/resources/what-makes-a-great-business-name' onclick='return reloadSiteContents("/resources/what-makes-a-great-business-name")'><span>What makes a great business name?</span></a><a href='https://www.brandbucket.com/resources/how-do-i-choose-the-right-name-for-my-business' onclick='return reloadSiteContents("/resources/how-do-i-choose-the-right-name-for-my-business")'><span>How to name your business</span></a><a href='https://www.brandbucket.com/resources/what-is-the-best-tld-for-a-business-domain-name' onclick='return reloadSiteContents("/resources/what-is-the-best-tld-for-a-business-domain-name")'><span>What is the best tld for a business domain name?</span></a><a href='https://www.brandbucket.com/resources/why-is-pronunciation-important-for-a-business-name' onclick='return reloadSiteContents("/resources/why-is-pronunciation-important-for-a-business-name")'><span>How important is pronunciation for a business name?</span></a><a href='https://www.brandbucket.com/resources/how-to-avoid-conflicts-when-choosing-a-business-name' onclick='return reloadSiteContents("/resources/how-to-avoid-conflicts-when-choosing-a-business-name")'><span>How to avoid business name conflicts</span></a><a href='https://www.brandbucket.com/resources/how-to-choose-a-unique-business-name' onclick='return reloadSiteContents("/resources/how-to-choose-a-unique-business-name")'><span>How to choose a unique business name</span></a><a href='https://www.brandbucket.com/resources/why-choose-a-business-name-with-longevity' onclick='return reloadSiteContents("/resources/why-choose-a-business-name-with-longevity")'><span>Why does business name longevity matter?</span></a><a href='https://www.brandbucket.com/resources/what-is-the-best-length-for-a-business-name' onclick='return reloadSiteContents("/resources/what-is-the-best-length-for-a-business-name")'><span>What is the best length for a business name?</span></a><a href='https://www.brandbucket.com/resources/why-are-some-letters-more-common-in-business-names' onclick='return reloadSiteContents("/resources/why-are-some-letters-more-common-in-business-names")'><span>What are the most common letters used in business names?</span></a><a href='https://www.brandbucket.com/resources/which-type-of-business-name-is-best-for-your-business' onclick='return reloadSiteContents("/resources/which-type-of-business-name-is-best-for-your-business")'><span>Which type of business name is best for your business?</span></a><a href='https://www.brandbucket.com/resources/how-does-spelling-affect-your-business-name' onclick='return reloadSiteContents("/resources/how-does-spelling-affect-your-business-name")'><span>How does domain name spelling affect your business?</span></a><a href='https://www.brandbucket.com/resources/can-real-words-and-expressions-be-good-business-names' onclick='return reloadSiteContents("/resources/can-real-words-and-expressions-be-good-business-names")'><span>Can real words and expressions be good business names?</span></a><a href='https://www.brandbucket.com/resources/how-to-choose-a-business-name-with-great-retention' onclick='return reloadSiteContents("/resources/how-to-choose-a-business-name-with-great-retention")'><span>Why you should consider retention when choosing a name for your business</span></a><a href='https://www.brandbucket.com/resources/why-business-name-generators-dont-work' onclick='return reloadSiteContents("/resources/why-business-name-generators-dont-work")'><span>Why business name generators don’t work</span></a><a href='https://www.brandbucket.com/resources/10-tips-for-creating-a-catchy-business-name' onclick='return reloadSiteContents("/resources/10-tips-for-creating-a-catchy-business-name")'><span>10 tips for creating a catchy business name</span></a><br /><strong>Domain Names 101</strong><a href='https://www.brandbucket.com/resources/what-is-a-domain-name' onclick='return reloadSiteContents("/resources/what-is-a-domain-name")'><span>What is a domain name?</span></a><a href='https://www.brandbucket.com/resources/what-is-a-domain-name-registrar' onclick='return reloadSiteContents("/resources/what-is-a-domain-name-registrar")'><span>What is a domain name registrar?</span></a><a href='https://www.brandbucket.com/resources/what-is-a-premium-domain-name' onclick='return reloadSiteContents("/resources/what-is-a-premium-domain-name")'><span>What is a premium domain name?</span></a><a href='https://www.brandbucket.com/resources/what-is-a-brandable-domain-name' onclick='return reloadSiteContents("/resources/what-is-a-brandable-domain-name")'><span>What is a brandable domain name?</span></a><a href='https://www.brandbucket.com/resources/why-a-com-domain-name-is-the-best-option' onclick='return reloadSiteContents("/resources/why-a-com-domain-name-is-the-best-option")'><span>Why is a .com domain name is the best option?</span></a><a href='https://www.brandbucket.com/resources/difference-between-business-names-brand-names-and-domain-names' onclick='return reloadSiteContents("/resources/difference-between-business-names-brand-names-and-domain-names")'><span>Difference between business names, brand names and domain names</span></a><br /><strong>Lean Branding 101</strong><a href='https://www.brandbucket.com/resources/what-is-a-lean-startup' onclick='return reloadSiteContents("/resources/what-is-a-lean-startup")'><span>What is a lean startup?</span></a><a href='https://www.brandbucket.com/resources/how-to-apply-the-lean-startup-methodology' onclick='return reloadSiteContents("/resources/how-to-apply-the-lean-startup-methodology")'><span>How to apply the lean startup methodology</span></a><a href='https://www.brandbucket.com/resources/what-is-lean-branding' onclick='return reloadSiteContents("/resources/what-is-lean-branding")'><span>What is lean branding?</span></a><a href='https://www.brandbucket.com/resources/how-to-apply-lean-branding-to-business-naming' onclick='return reloadSiteContents("/resources/how-to-apply-lean-branding-to-business-naming")'><span>How to apply lean branding to business naming?</span></a><a href='https://www.brandbucket.com/resources/how-to-brainstorm-domain-names-the-lean-way' onclick='return reloadSiteContents("/resources/how-to-brainstorm-domain-names-the-lean-way")'><span>How to brainstorm domains the lean way</span></a><br /><strong>Business Name Trends</strong><a href='https://www.brandbucket.com/resources/top-cannabis-business-names' onclick='return reloadSiteContents("/resources/top-cannabis-business-names")'><span>Top cannabis business names</span></a> </div>
<div class='h_30'></div>
</div>
<div class='left_menu_panel left_menu_panel_faq darkerback2'>
<div class='left_menu_big_links'>
<a href='#' onclick='return site_leftMenu_showPanel("main", 1);' class='menu_link_return'><span>Back</span></a>
<strong>How BrandBucket Works</strong><a href='https://www.brandbucket.com/faq/why-use-brandbucket-to-find-a-business-name' onclick='return reloadSiteContents("/faq/why-use-brandbucket-to-find-a-business-name")'><span>Why use BrandBucket to find a business name?</span></a><a href='https://www.brandbucket.com/faq/who-are-brandbucket-customers' onclick='return reloadSiteContents("/faq/who-are-brandbucket-customers")'><span>Who are BrandBucket customers?</span></a><a href='https://www.brandbucket.com/faq/who-are-the-people-behind-brandbucket' onclick='return reloadSiteContents("/faq/who-are-the-people-behind-brandbucket")'><span>Who are the people behind BrandBucket?</span></a><a href='https://www.brandbucket.com/faq/how-does-brandbucket-curate-its-names' onclick='return reloadSiteContents("/faq/how-does-brandbucket-curate-its-names")'><span>How does BrandBucket curate its names?</span></a><a href='https://www.brandbucket.com/faq/how-do-i-find-a-name-on-brandbucket' onclick='return reloadSiteContents("/faq/how-do-i-find-a-name-on-brandbucket")'><span>How do I find a name on BrandBucket?</span></a><a href='https://www.brandbucket.com/faq/what-type-of-names-will-i-find-on-brandbucket' onclick='return reloadSiteContents("/faq/what-type-of-names-will-i-find-on-brandbucket")'><span>What type of names will I find on BrandBucket?</span></a><a href='https://www.brandbucket.com/faq/what-domain-extensions-does-brandbucket-offer' onclick='return reloadSiteContents("/faq/what-domain-extensions-does-brandbucket-offer")'><span>What domain extensions does BrandBucket offer?</span></a><a href='https://www.brandbucket.com/faq/what-do-i-get-when-i-buy-a-name-from-brandbucket' onclick='return reloadSiteContents("/faq/what-do-i-get-when-i-buy-a-name-from-brandbucket")'><span>What do I get when I buy a name from BrandBucket?</span></a><a href='https://www.brandbucket.com/faq/does-my-brandbucket-name-come-with-a-trademark' onclick='return reloadSiteContents("/faq/does-my-brandbucket-name-come-with-a-trademark")'><span>Does my BrandBucket name come with a trademark?</span></a><a href='https://www.brandbucket.com/faq/how-do-i-buy-a-name-on-brandbucket' onclick='return reloadSiteContents("/faq/how-do-i-buy-a-name-on-brandbucket")'><span>How do I buy a name on BrandBucket?</span></a><a href='https://www.brandbucket.com/faq/what-happens-after-i-buy-a-name-from-brandbucket' onclick='return reloadSiteContents("/faq/what-happens-after-i-buy-a-name-from-brandbucket")'><span>What happens after I buy a name from BrandBucket?</span></a><a href='https://www.brandbucket.com/faq/what-is-brandbuckets-refund-policy' onclick='return reloadSiteContents("/faq/what-is-brandbuckets-refund-policy")'><span>What is BrandBucket's refund policy?</span></a> </div>
<div class='h_30'></div>
</div>
</div>
<div class='right_menu_fake_header d_none'><img src='/images5/head_logo_black_lock.png' alt='BrandBucket logo' /></div>
<div class='page_right_menu_holder cart_vat_hidden page_menu_white w_0' style='display: none'><div class='inner_width'>
<div class='scrollable white_inputs'>
<table class='white_tab' cellspacing='0' cellpadding='0' width='100%'><tbody><tr>
<td id='cart_right_tab' onclick='return site_showRightMenu("cart", 1, 1)'>
<img src='/images6/icon_cart_blk.png' alt='Icon Cart' /><span> Cart</span>
</td>
<td id='fav_right_tab' onclick='return site_showRightMenu("fav", 1, 1)'>
<img src='/images6/icon_heart.png' alt='Icon Favorites' /><span> Favorites</span>
</td>
<td id='search_right_tab' onclick='return site_showRightMenu("search", 1, 1)'>
<img src='/images6/icon_bc_search_blk.png' alt='Icon Search' style='opacity: 1' /><span> Search</span>
</td>
<td class='close'><div><a href="/" onclick='$(".page_contents_over").trigger("click"); return false'><img src='/images6/icon_bc_remove.png' alt='Icon Remove' /></a></div></td>
</tr></tbody></table>
<div class='page_right_menu d_none' id='cart_right_menu' reload='/cart' needs_reload=1>
Loading...
</div>
<div class='page_right_menu d_none' id='fav_right_menu' reload='/favorites' needs_reload=1>
Loading...
</div>
<div class='page_right_menu d_none' id='search_right_menu'><div class='load_area'>
<div class="left_menu_search">
<form onsubmit="return reloadSiteContents({ q: $('#search_right_menu input[name=keyword]').val(), clear: true, trigger_GA_event: true });" action="">
<input type="submit" value="" />
<input type="text" name="keyword" value="" />
</form>
</div>
<div id='search_right_menu_history' class='darkerback'></div>
<div id='search_right_menu_related' class='darkerback'></div>
<div id='search_right_menu_common' class='darkerback'>
<b style='padding-top: 10px; display: inline-block'>Common search terms</b>:<br />
<a href='https://www.brandbucket.com/search?q=green&source=side' onclick='return reloadSiteContents({ q: "green". source: "side" })' rel='nofollow'>green</a><br /><a href='https://www.brandbucket.com/search?q=hello&source=side' onclick='return reloadSiteContents({ q: "hello". source: "side" })' rel='nofollow'>hello</a><br /><a href='https://www.brandbucket.com/search?q=bit&source=side' onclick='return reloadSiteContents({ q: "bit". source: "side" })' rel='nofollow'>bit</a><br /><a href='https://www.brandbucket.com/search?q=spark&source=side' onclick='return reloadSiteContents({ q: "spark". source: "side" })' rel='nofollow'>spark</a><br /><a href='https://www.brandbucket.com/search?q=express&source=side' onclick='return reloadSiteContents({ q: "express". source: "side" })' rel='nofollow'>express</a><br /><a href='https://www.brandbucket.com/search?q=stack&source=side' onclick='return reloadSiteContents({ q: "stack". source: "side" })' rel='nofollow'>stack</a><br /><a href='https://www.brandbucket.com/search?q=mode&source=side' onclick='return reloadSiteContents({ q: "mode". source: "side" })' rel='nofollow'>mode</a><br /><a href='https://www.brandbucket.com/search?q=vibe&source=side' onclick='return reloadSiteContents({ q: "vibe". source: "side" })' rel='nofollow'>vibe</a><br /><a href='https://www.brandbucket.com/search?q=lab&source=side' onclick='return reloadSiteContents({ q: "lab". source: "side" })' rel='nofollow'>lab</a><br /><a href='https://www.brandbucket.com/search?q=social&source=side' onclick='return reloadSiteContents({ q: "social". source: "side" })' rel='nofollow'>social</a><br /> </div>
</div></div>
<div class='page_right_menu d_none' id='refine_box_right_menu'><div class='load_area pad_top_0'>
<div class='white_tab_header'>
<div class='close'><a href="/" onclick='$(".page_contents_over").trigger("click"); return false'><img src='/images6/icon_bc_remove_wh.png' alt='Icon Remove' /></a></div>
<img src='/images6/icon_bc_refine_wh.png' alt='Icon Refine' style='opacity: 1; margin-right: 10px;' /><span class='medium'>Refine</span><br />
</div><br />
<a href='#' class='clear_all' onclick='return reloadSiteContents("clear");'>Clear all</a>
Brand type: <span class='refine_segment'>All</span>
<div class='refine_bar_area' refine='segment' value=''>
<div class='select_div'></div>
<table><tbody><tr>
<td>All</td>
<td value='invented'>Invented</td>
<td value='keyword'>Keyword</td>
</tr></tbody></table>
</div>
<br />
TLD extension: <span class='refine_tld'>All</span><br />
<div class='refine_bar_area' refine='tld' value=''>
<div class='select_div'></div>
<table><tbody><tr>
<td>All</td>
<td value='com'>.com</td>
<td value='io'>.io</td>
<td value='ly'>.ly</td>
<td value='me'>.me</td>
</tr></tbody></table>
</div>
<br />
Max Length: <span class='refine_chars'>All</span><br />
<div class='refine_bar_slider' refine='chars' snap='3,4,5,6,7,8,9,10,100' value='100'>
<div class='bar'></div>
<div class='bullet'></div>
</div>
<br />
Price Range: <span class='refine_price'>All</span><br />
<div class='refine_bar_slider' refine='price' snap='0,1000,1500,1750,2000,2250,2500,3000,3500,4000,4500,5000,5500,6000,6500,7000,7500,8000,9000,10000,15000,20000,25000' value_min='0' value_max='25000'>
<div class='bar'></div>
<div class='bullet bullet_min'></div>
<div class='bullet bullet_max'></div>
</div>
<br />
<div style='padding-bottom: 10px;'>Sort By: </div>
<div class='ui-select refine_dropdown' refine='sort_by'>
<select class='refine_dropdown'>
<option value='relevance' selected='selected'>Relevance</option>
<option value='date'>Date added</option>
<option value='alpha'>First letter alphabetically</option>
<option value='price'>Price High to Low</option>
</select>
</div>
<br />
<div class='pad_top_15' id='refine-buttons'>
<table width='100%' cellpadding='0' cellspacing='0'><tbody><tr>
<td width='50%'><a href='#' onclick='$(".page_contents_over").trigger("click"); return false;' class='cart_btn cancel_cart_btn'>Cancel</a></td>
<td><div style='width: 10px'></div></td>
<td width='50%'><a href='#' class='cart_btn' onclick='return reloadSiteContents("refine_box")'>Apply</a></td>
</tr></tbody></table>
</div>
</div></div>
<div style='height: 30px; float: left'></div>
</div>
</div></div>
<div class="dummy_head_search_text"></div>
<div class='page_extra_var d_none'></div>
<div class='optin_dialogue newsletter_popup'>
<form onsubmit="return site_processSubscribeForm(this, 'Popup')" method="post" action="/">
<h2 class='color_4' style='margin: 0 0 10px;'>Fresh Names Every Friday!</h2>
<div class='color_6' style='margin: 8px auto; max-width: 380px; line-height: 1.5em'>
Subscribe and get a weekly digest of all of our new names.
</div>
<input type="hidden" name="from_popup" value="1" />
<input type="email" name="my_mail" id="optin_signup_my_email" placeholder="Email address" /><br />
<label for="optin_signup_my_email">
<input type="submit" value="Sign Me Up" class="submit_button" />
</label>
<br /><br />
<a href='#' onclick='return preventFuturePopup()'>No thanks</a>
<br /><br />
<span class='color_6' style='font-size: 0.8em'>We respect your privacy. Your information is safe and will never be shared. You can opt-out at any time.</span>
</form>
</div>

<script type='text/javascript'> window.dataLayer = window.dataLayer ||[];guard_site_pageInitDivs();$(function (){var pixels_onload = function (){if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(pixels_onload,50);return;}if (!window.__pixels_loaded){setTimeout(pixels_onload,50);window.__pixels_loaded = true;return;}$("<script type='text/javascript' src='https://js.stripe.com/v3/' async></"+"script>").appendTo("body");};pixels_onload();});</script>
<div class="my-loader"><span class="ui-icon-loading"></span><p class='font_16 bold'>Loading...</p></div>
<script type="text/javascript" src="/js/minified.js?132"></script>
</body><script>console.log("Cache hit - 36m37s");</script></html>
